Patrick Hunt commented on ZOOKEEPER-640:

@Thomas I subscribed to the page you listed so hopefully I'll be notified of 
any changes in future.

the "no network no download" may be a problem. In 3.3.0 we've upgraded to ivy 
(already used by
much of the rest of the hadoop projects) and as part of that change ivy will 
d/l any/all necessary
dependencies during the build. I guess we'll have to cross that bridge at some 

so you are ok with the changes listed in this patch then? It addressed your 
current concern/problems?

> make build.xml more configurable to ease packaging for linux distros
> --------------------------------------------------------------------
>                 Key: ZOOKEEPER-640
>                 URL: https://issues.apache.org/jira/browse/ZOOKEEPER-640
>             Project: Zookeeper
>          Issue Type: Improvement
>          Components: build
>    Affects Versions: 3.2.1, 3.2.2
>            Reporter: Thomas Koch
>            Assignee: Patrick Hunt
>             Fix For: 3.3.0
>         Attachments: ZOOKEEPER-640.patch
>   Original Estimate: 0.25h
>  Remaining Estimate: 0.25h
> Hi,
> I started packaging Zookeeper for Debian[1][2]. Thereby I had a problem 
> excluding contrib/rest from the build without patching the upstream tarball. 
> Could you please add some properties to your build.xml that allow me to 
> (de)select contribs? In the example below I can easily override the 
> properties:
> <project name="zookeepercontrib">
>   <property name="contribfilesetincludes" value="*/build.xml" />
>   <property name="contribfilesetexcludes" value="" />
>   <fileset id="contribfileset" 
>            dir="." 
>            includes="${contribfilesetincludes}"
>            excludes="${contribfilesetexcludes}"
>            />
>   <target name="compile">
>     <subant target="jar">
>      <fileset refid="contribfileset" />
>     </subant>
>   </target>
> Could you please also add a line to project.classpath:
>   <path id="project.classpath">
>       <fileset dir="${additional.lib.dir}" includes="*.jar"/>
> For Debian I may not compile based on the jar files in lib but must use the 
> jars already in Debian.
> [1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=561947
> [2] http://git.debian.org/?p=pkg-java/zookeeper.git
> Thank you!

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

Reply via email to