> 3.) Zope 2.8 warnings
> 'Zope2' is not available in Zope 2.7 and 'Zope' is deprecated in Zope
> 2.8. Same with 'transaction' and 'get_transaction'.
> Has anybody a better idea to resolve it than this way:

Well, the deprecation procedures and warning is there to tell you that
you are using a way that works no, but will stop working later. The
standard pattern when you need to support both the version where they
are deprecated, and the version where they are not, is to do
nothing... And then when you no longer need to support the older
version, you move up to the new non-deprecated API.
Lennart Regebro, Nuxeo     http://www.nuxeo.com/
CPS Content Management     http://www.cps-project.org/
Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to