Hi Tres!

Tres Seaver wrote:
I have need of using GenericSetup 1.1 on an older Zope / Five (2.8.6,
1.0.3), and found I needed to patch around some BBB breakage in imports
/ ZCML.  In particular:

Even after this patch, a number of the GenericSetup unit tests fail
(mostly, in the sub-packages), but enough stuff works that I can move

Any objections to landing it on the 1.1 branch, as well as the trunk?  I
don't recall that we had a specific Zope / Five version designated as
"minimum required version" for GenericSetup (as opposed to CMF 2.0).

GenericSetup/DEPENDENCIES.txt says:

Zope >= 2.8.5
Five >= 1.2

Is upgrading to Five 1.2 no option for you?

I'm not happy with adding BBB code for incomplete Five 1.0 support. I even did consider to propose removing Zope 2.8 compatibility on the trunk.



Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See http://collector.zope.org/CMF for bug reports and feature requests

Reply via email to