Wichert Akkerman, on 2008-09-08:
> While working on plonenext I get an error when trying to install
> the Products.CMFDefault egg. This is the buildout -vv output:
> While:
>   Installing instance.
>   Getting distribution for 'Products.CMFDefault'.
> Error: Couldn't install: Products.CMFDefault 2.1.2-beta
> Which is not very informative. Does anyone know what might cause this?

Not very informative indeed.  bin/buildout -Nv in plonenext gives me
this more informative output instead:

  Installing instance.
Error: There is a version conflict.
We already have: Products.GenericSetup 1.4.1
but Products.CMFActionIcons 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.CMFCalendar 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.CMFCore 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.CMFDefault 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.CMFTopic 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.CMFUid 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.
but Products.DCWorkflow 2.1.2-beta requires 'Products.GenericSetup==1.3.3'.

So the question is: why are those products depending on GS 1.3.3?  GS
1.4 has been out for a while.

Maurits van Rees | http://maurits.vanrees.org/
            Work | http://zestsoftware.nl/
"This is your day, don't let them take it away." [Barlow Girl]

Zope-CMF maillist  -  Zope-CMF@lists.zope.org

See https://bugs.launchpad.net/zope-cmf/ for bug reports and feature requests

Reply via email to