> Zope 3X requires Python 2.2b2.

Shane

Are you sure you mean Python2.2b2?

I tried this but seem to get problems with the pyexpat module.

Would a different version do, Or have you solved any problems with the
pyexpat module in 2.2.b2?

I have added a few print statements to my xml.sax.__init__.py and
commented out the try, except block around the import of expatreader.py
lines 16,18-22

This gives me a more usfull traceback:

[root@legolas Zope3]# python2.2 z3.py
['xml.sax.expatreader']
xml.sax.expatreader
Traceback (most recent call last):
  File "z3.py", line 38, in ?
    config(os.getcwd())
  File "/usr/local/zope/Zope3/lib/python/Zope/App/config.py", line 34,
in config
    xmlconfig(file)
  File
"/usr/local/zope/Zope3/lib/python/Zope/Configuration/xmlconfig.py", line
96, in xmlconfig
    parser=make_parser()
  File "/usr/local/Python2.2b2/Lib/xml/sax/__init__.py", line 83, in
make_parser
    return _create_parser(parser_name)
  File "/usr/local/Python2.2b2/Lib/xml/sax/__init__.py", line 107, in
_create_parser
    drv_module = __import__(parser_name,{},{},['create_parser'])
  File "/usr/local/Python2.2b2/Lib/xml/sax/expatreader.py", line 17, in
?
    from xml.parsers import expat
  File "/usr/local/Python2.2b2/Lib/xml/parsers/expat.py", line 4, in ?
    from pyexpat import *
ImportError: No module named pyexpat

Cheers

-AndyD

_______________________________________________
Zope-Dev maillist  -  [EMAIL PROTECTED]
http://lists.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-announce
 http://lists.zope.org/mailman/listinfo/zope )

Reply via email to