Chris McDonough wrote:
On Mon, 2004-05-17 at 13:06, Steve Jibson wrote:

I'm sure 'accountType' should have been in the session. Immediately after a user logs in we populate his session with a bunch of stuff (including accountType).

What happens when the session expires and he's still logged in?

We're using ExUserFolder for authentication. We have it set to log users out after 10 minutes. We have sessions set to expire after 20 minutes. So, in theory, it should never happen. Also, since my last Zope restart (3hr 30min), I've had 57 users let their authentication timeout and then access the site (forcing another login), and still no errors with session. (It's still using FileStorage).

1 - After having the system run for 45 minutes, I had 8 similar errors. Some were on different web pages and some had different "keys" that were causing the error.
2 - I have also traced through Z2.log and followed the same path through the web site that produced one of the errors and I did not get an error.
3 - Since changing this server to use FileStorage (1hr 39min ago), there has not been a single error.

Is there anything I can do to help here?

A small reproducible test case would help if you still believe this
error is not in your own application.

I'm sure you know by now that this is easier said than done. Over the past few weeks, I've probably put close to 30 hours into just trying to reproduce (on demand) these session errors. I'll probably want to look at the test rig you and Michael have been using.

Zope-Dev maillist - [EMAIL PROTECTED]
** No cross posts or HTML encoding! **
(Related lists - )

Reply via email to