--On 5. Juli 2006 19:00:52 +0100 Tim Hicks <[EMAIL PROTECTED]> wrote:

Florent Guillaume wrote:
Is anyone opposed to me removing the stupid:
        _getattr = getattr
        _none = None
        marker = _marker
local namespace """optimizations""" that are found in

I find these things rather confusing when looking at zope core code, and
always wondered why they were there.  In what sense are they

Evil tricks from the ancient Zope world. Such lookups were faster because the items were directly found in the local namespace so one saved time looking them up in the global namespace.


Attachment: pgprvSImjP47F.pgp
Description: PGP signature

Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to