On Monday 08 December 2008, Benji York wrote:
> Nope, the tests will pass in the zope.testbrowser buildout.
> However, if a testbrowser user for some reason run the testbrowser tests
> outside of its buildout, then you're right, they may see a failure if
> their versions aren't new enough.  At that point I would hope they would
> read the CHANGES.txt and see that a new version is required.
> The trade off is in requiring people to upgrade a dependency in order to
> get a bug fix that they may not care about.
> In the large, this is the problem with specifying versions in setup.py.
> Doing so assumes too much about how people are using all the
> dependencies involved.

Yep, I could not agree more. :-)

Stephan Richter
Web Software Design, Development and Training
Google me. "Zope Stephan Richter"
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to