Andreas Jung wrote at 2009-3-15 08:48 +0100:
> ... Zope2 2.12.1a1 version conflict ...
> ...
>In addition: setuptools 0.6c7 is pretty old and known to be broken in
>some ways.

As expected, "setuptool 0.6.c7" was not the problem.
After "easy_install -U setuptools", an "easy_install -U Zope2"
leads to

(zcpython)newdm: easy_install -U Zope2
Searching for Zope2
Reading http://pypi.python.org/simple/Zope2/
Reading http://www.zope.org
Best match: Zope2 2.12.0.a1
Processing Zope2-2.12.0.a1-py2.5-linux-i686.egg
Zope2 2.12.0.a1 is already the active version in easy-install.pth
Installing zpasswd script to /home/dieter/ZopeSVN/ZClasses/zcpython/bin
Installing mkzeoinstance script to /home/dieter/ZopeSVN/ZClasses/zcpython/bin
Installing mkzopeinstance script to /home/dieter/ZopeSVN/ZClasses/zcpython/bin

Using 
/home/dieter/ZopeSVN/ZClasses/zcpython/lib/python2.5/site-packages/Zope2-2.12.0.a1-py2.5-linux-i686.egg
Processing dependencies for Zope2
Searching for zope.component==3.5.1
Reading http://pypi.python.org/simple/zope.component/
Best match: zope.component 3.5.1
Downloading 
http://pypi.python.org/packages/source/z/zope.component/zope.component-3.5.1.tar.gz#md5=006c43ad77ed4982e49c07f6e65b68a2
Processing zope.component-3.5.1.tar.gz
Running zope.component-3.5.1/setup.py -q bdist_egg --dist-dir 
/tmp/easy_install-KtgqcP/zope.component-3.5.1/egg-dist-tmp-3BefxU
Adding zope.component 3.5.1 to easy-install.pth file

Installed 
/home/dieter/ZopeSVN/ZClasses/zcpython/lib/python2.5/site-packages/zope.component-3.5.1-py2.5.egg
error: Installed distribution zope.component 3.5.1 conflicts with requirement 
zope.component>=3.6.0



-- 
Dieter
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
http://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-announce
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to