Chris Withers wrote:
> Got zope.principalregistry 3.7.0.
> While:
>    Installing zopetest.
> Error: There is a version conflict.
> We already have: zope.component 3.5.1
> but 3.7.0 requires 'zope.component>=3.6.0'.

Okay, so I thought I'd be smart and try the following buildout.cfg:

parts = zopetest
versions = versions


recipe = zc.recipe.egg
interpreter = py
eggs =

But this still burps:

We have the distribution that satisfies 'zope.configuration==3.4.1'.
The version, =3.6.0, is not consistent with the requirement, 
   Installing zopetest.
Error: Bad version =3.6.0

Okay, so the 2.12.0.a1 zope2 egg specifies zope.component 3.5.1, fair 
enough, so lets dig into what wants zope.component 3.6.0...

As the original error messages says, it's 3.7.0 that 
wants zope.component 3.6.0.

But wait, zope2 2.12.0.a1 SPECIFIES a hard requirement of 3.6.0.

What the hell is 3.7.0 doing being dragged down?
Is this a buildout snafu? Jim?


Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to