Hi there, What do people feel about dropping Python 2.4 support in the Zope Toolkit? I.e. new releases of packages in the Zope Toolkit (handwave vaguely as we *still* don't have a canonical list) only have to work in Python 2.5 (and preferably 2.6), not Python 2.4 anymore.
(this won't affect Zope 3.4 or below) One issue that came up recently was that .tgz releases to PyPI sometimes break with Python 2.4 due to a bug in Python 2.4. Using --zip is a workaround. And Plone currently depends on Python 2.4. Is it possible to work around this by *also* uploading a zip if we discover there's a problem with a package and it's pointed out there? If not, are there other workarounds? What do Zope 2 and Plone people in general think about moving to Python 2.5 for the newer releases? I'll note we're shuffling around the dependency structure so much in the Zope Toolkit it's unlikely everything will remain compatible for that reason as well. Regards, Martijn _______________________________________________ Zope-Dev maillist - Zope-Dev@zope.org http://mail.zope.org/mailman/listinfo/zope-dev ** No cross posts or HTML encoding! ** (Related lists - http://mail.zope.org/mailman/listinfo/zope-announce http://mail.zope.org/mailman/listinfo/zope )