Hash: SHA1

Fabio Tranchitella wrote:

> Zope 2 and Plone
> ================
> Zope 2 and Plone are obviously related, so the future of one of the two
> influences the other one.
> The main problem for Zope2 is that the current stable upstream branch
> (2.12) still requires python2.4.

Incorrect:  Zope 2.12 is supported only on Python 2.5 / 2.6.  The
INSTALL.rst[1] file says:


 System requirements when building from source

 - A supported version of Python, including the development support if
   installed from system-level packages.  Supported versions include:

   * 2.5.x, (x >= 4)

   * 2.6.x

 - Zope needs the Python ``zlib`` module to be importable.  If you are
   building your own Python from source, please be sure that you have
   the headers installed which correspond to your system's ``zlib``.

 - A C compiler capable of building extension modules for your Python
   (gcc recommended).

> This is not acceptable in Debian and
> Ubuntu, and Zope 2 is right now the only stopper for the removal of
> python2.4 from both Debian and Ubuntu.
> Even worse, the current stable Plone releases requires Zope 2.10, which we
> suppose will never support anything but python2.4 in the foreseeable
> future. The new major upstream branch (Plone 4) is still far from being 
> released, which means
> that the only way to support Plone and Zope 2.x in Debian and Ubuntu is to
> keep python2.4 in the distribution.

Plone 4.0 is slated be released this year, with an explicit goal of
running on Zope 2.12 / Python 2.{5,6}][1].

> For this reason, together with the upstream suggestions to use the unified
> installer and zc.buildout as primary tools for deploying Zope 2 and Plone,
> the Debian/Ubuntu Zope Team decided to drop support for Zope 2, Plone and
> all the other Zope 2 products. We will file requests of removal for all the
> Zope and Plone packages from the archive.

In the short term, I would just update the existing packages to use
Python 2.5, which is "known to work" with Zope 2.10.

[1] http://svn.zope.org/Zope/branches/2.12/doc/INSTALL.rst?view=auto

[2] http://article.gmane.org/gmane.comp.web.zope.plone.teams.framework/2767

- --
Tres Seaver          +1 540-429-0999          tsea...@palladion.com
Palladion Software   "Excellence by Design"    http://palladion.com
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope )

Reply via email to