2009/8/28 Stephan Richter <srich...@cosmos.phy.tufts.edu>:
> On Thursday 27 August 2009, Dan Korostelev wrote:
>> Well, I thinked about that, but it was hard to choose the right way.
>> zope.container 3.8.3 doesn't really have any API changes, the only
>> thing that was changed is that two zcml adapter registration was added
>> to configure.zcml (and those adapters were are already in
>> zope.container). No python changes, no dependency changes. Does it
>> really worth a new "feature release"? New zope.app.publisher needs
>> this adapter registration for its functional tests though, so it won't
>> work with older zope.container versions.
>
> Yes, because people need to be aware that there are now 2 new adapter
> registrations around, which might in fact interfere with their registrations.
>
>> Should I release zope.container 3.9.0 and then zope.app.publisher
>> 3.10.0 only because of that thing? (note that it's only a test
>> dependency requirement)
>
> Definitely create a zope.container 3.9.0 release.

That's done.

> I forgot what we said about changing dependencies, but I am pretty sure
> they also always require a major update, so yes, 3.10.0 for 
> zope.app.publisher.

Hmm, that change looks more like a bug fix to me (the dependencies
were wrong in the previous release of zope.app.publisher and now they
are fixed), so may be it should be 3.9.1 nevertheless?

-- 
WBR, Dan Korostelev
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to