On Wed, Sep 9, 2009 at 2:40 PM, Martijn Faassen<faas...@startifact.com> wrote:
> Christian Theune wrote:
>> However, this requires Subversion 1.5 which we are using on the server
>> already, but I don't know whether we assume clients are 1.5 or higher.
>
> I certainly still use a SVN 1.4.x client, being on Ubuntu 8.04 LTS
> (released just last year). I don't think SVN 1.5 is common enough yet to
> make such a move possible.

We moved all the Plone repositories (including the rather massively
used collective) to Subversion 1.5.6 a while ago. So far there have
been no complaints by anyone. And as Robert noted you can use a
Subversion 1.4 client with a 1.5 server just fine.

I think doing the server upgrade very soon (tm) shouldn't be a problem.

Using relative externals or proper merge history might be something
that shouldn't be required yet, though. Maybe people should be free
and allowed to do this for any package not being part of the ZTK right
away. That might introduce some incentive for those still using
age-old Subversion clients ;)

Hanno
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to