Chris Withers wrote:
> I'd propose just having:
> 3.x -> old semantics
> 4.x -> new semantics

That's the Python 3 upgrade scenario, without conversion scripts even. :)

I think this would block people from upgrading to use the new semantics 
way too long, as they'd need to ensure all their dependencies are 
upgraded as well. It'd be hard to manage for those mixing and matching 
libraries. I'm definitely -1 to such a path.



Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to