On Mon, Dec 7, 2009 at 08:27, Wolfgang Schnerring <w...@gocept.com> wrote:
> When I worked on py3 stuff on the DZUG sprint in September, we broke out
> of that catch-22 by porting zope.testing first, and running its test
> using <http://pypi.python.org/pypi/discover>, patched[1] to pick up
> tests via the test_suite() methods. That way we could run the tests of
> zope.testing under py3 without needing zope.testing itself or
> zc.buildout to do so, so porting zope.testing could be tackled.

That doesn't seem to work. If I use discover withing setup.py, I get
the same problems as using the standard setuptools testrunner. If I
have a custom script that I run to run the tests, the tests seem to
get stuck in some sort of infinite regression and never end.

It's really strange that running tests with setuptools fails. I think
the best way forward is to try to figure out why, but I have no idea
when or if I'm able to do that.

Lennart Regebro: Python, Zope, Plone, Grok
+33 661 58 14 64
Zope-Dev maillist  -  Zope-Dev@zope.org
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to