FYI: I solved it. As usual the solution was dead simple once it struck me.

I made a custom test command for setuptools, that simply create a
temporary script modeled after the bin/test script that buildout would
create, and call that. Problem solved!

On Mon, Dec 7, 2009 at 16:24, Lennart Regebro <> wrote:
> On Mon, Dec 7, 2009 at 15:46, Lennart Regebro <> wrote:
>> That doesn't seem to work. If I use discover withing, I get
>> the same problems as using the standard setuptools testrunner. If I
>> have a custom script that I run to run the tests, the tests seem to
>> get stuck in some sort of infinite regression and never end.
>> It's really strange that running tests with setuptools fails. I think
>> the best way forward is to try to figure out why, but I have no idea
>> when or if I'm able to do that.
> The problem here is that the tests for the test runner assumes that
> the tests are run via the test script created by the buildout, and
> must call that script to test itself. This needs to be changed,
> somehow. I'll think about it, and see if I can come up with a
> solution.
> --
> Lennart Regebro: Python, Zope, Plone, Grok
> +33 661 58 14 64
Zope-Dev maillist  -
**  No cross posts or HTML encoding!  **
(Related lists - )

Reply via email to