On Tue, Dec 8, 2009 at 12:55, Jim Fulton <j...@zope.com> wrote:
> On Tue, Dec 8, 2009 at 6:29 AM, Lennart Regebro <rege...@gmail.com> wrote:
>> On Mon, Dec 7, 2009 at 23:20, Lennart Regebro <rege...@gmail.com> wrote:
>>> OK, I'm going to try to remove doctest.py from my branch
>>
>> Done. There are two tests that still fail under Python 2.x:
>>
>> unicode.txt:
>>
>> "There was another unicode bug. When a function returned unicode some 
>> internal
>> state switched. This broke any further test not returning unicode but a plain
>> string with unicode characters. Make sure this works now::"
>>
>> Well, it doesn't.
>>
>> testrunner-repeat.txt:
>>
>> The second repetition of the test fails, it seems all local variables
>> suddenly are gone. Loads of "NameError: name 'x' is not defined". No
>> idea how that happened.
>>
>>
>> I assume these are errors fixed in zope.testings copy of doctest, but
>> never in stdlib. Maybe Jim knows?
>
> The unicode test relates to a feature that was added to both the
> stdlib doctest and the zope.testing doctest. This was some time ago. I
> don't remember any details.
>
> I don't recall any special changes in the zope.testing version of
> doctest to support repetition.

OK. I have no clue, it's clearly complex bugs, and I've spent two days
on zope.testing already, so I'm taking a break from the Python 3
porting of the ZCA.

If anyone wants to dig into these bugs the branch is
http://svn.zope.org/zope.testing/branches/regebro-python3-reloaded/

-- 
Lennart Regebro: Python, Zope, Plone, Grok
http://regebro.wordpress.com/
+33 661 58 14 64
_______________________________________________
Zope-Dev maillist  -  Zope-Dev@zope.org
https://mail.zope.org/mailman/listinfo/zope-dev
**  No cross posts or HTML encoding!  **
(Related lists - 
 https://mail.zope.org/mailman/listinfo/zope-announce
 https://mail.zope.org/mailman/listinfo/zope )

Reply via email to