Stack size doesn't seem to be the issue.  The HP box is set
to 31116 Kb.  The recommendation on early releases of Mac
OS X was 4096 Kb.  Good idea though!

Does anyone have any ideas on why the unittest would fail?
Specifically, the testLargeBody method in test_httpserver.py?
it calls a method "loop":

def loop(self):
    self.thread_started.set()
    while self.run_loop:
        self.counter = self.counter + 1
        #print 'loop', self.counter
        poll(0.1)

which loops forever.  Why would this happen on HP-UX and 
not on other systems?  I'm not to familiar with socket
programming and the poll() call.  Is there some peculiarity
with the underlying poll() and select() calls on HP-UX
that I have to make adjustments for?

I really appreciate any tips or insight!

--- Chris McDonough <[EMAIL PROTECTED]> wrote:

> I don't know much about HPUX, but one issue that seems to plague a  
> lot of less-frequently-used platforms is stack sizes.  For example,  
> for a while in FreeBSD and on MacOS, you needed to explicitly bump up  
> the thread stack size.  See doc/PLATFORMS/BSD.txt in the Zope release  
> for an idea about how to do this.
> 
> - C
> 
> 
> On Oct 5, 2005, at 10:08 AM, Chris Leonello wrote:
> 
> > I have been successfully running for many months on Windows XP and Mac
> > OS X.  I cannot get the server to run on HP-UX, however.  I can build
> > and install o.k., but when I visit http://127.0.0.1:8080/ in the
> > browser, the process either hangs (built under python 2.3.5) or
> > terminates with a bus error (built under python 2.4.1 or 2.4.2).  In
> > any case, the (verbose) output from the runzope process looks like
> > this:
> >
> > ------
> > 2005-10-03T17:34:31 WARNING ZODB.FileStorage Ignoring index for
> > /ford/et17112/u/cleonell/cusr/local/zopehome/var/Data.fs
> > ------
> > 2005-10-03T17:34:31 INFO PublisherHTTPServer zope.server.http (HTTP)
> > started.
> >         Hostname: et17112
> >         Port: 8080
> > ------
> > 2005-10-03T17:34:31 INFO PublisherFTPServer zope.server.ftp started.
> >         Hostname: et17112
> >         Port: 8021
> > ------
> > 2005-10-03T17:34:31 INFO root Startup time: 20.685 sec real, 12.460  
> > sec
> > CPU
> > #
> > /ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/ 
> > locales/xmlfactory.pyc
> > matches
> > /ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/ 
> > locales/xmlfactory.py
> > import zope.i18n.locales.xmlfactory # precompiled from
> > /ford/et17112/u/cleonell/cusr/local/Zope-3.1.0/lib/python/zope/i18n/ 
> > locales/xmlfactory.pyc
> > #
> > /ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/ 
> > expatbuilder.pyc
> > matches
> > /ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/ 
> > expatbuilder.py
> > import xml.dom.expatbuilder # precompiled from
> > /ford/et17112/u/cleonell/cusr/local/lib/python2.3/xml/dom/ 
> > expatbuilder.pyc
> > Terminated (If I killed process or Bus Error under python 2.4.1/.2)
> >
> > I don't know if the initial warning is significant or not.
> >
> > I don't know if this is related or not, but the test suite (compiled
> > under python 2.3.5) hangs on testLargeBody:
> >
> > 6692/6990 ( 95.7%): testChunkingRequestWithoutContent
> > (zope.server.http.tests.test_httpserver.Tests) ... ok
> > 6693/6990 ( 95.8%): testEchoResponse
> > (zope.server.http.tests.test_httpserver.Tests) ... ok
> > 6694/6990 ( 95.8%): testLargeBody
> > (zope.server.http.tests.test_httpserver.Tests) ...
> >
> > It gets caught in an infinite loop in the "loop" method (I killed it
> > after 55,000 iterations).
> >
> > Any help or feedback is appreciated.  Thanks!
> >
> > Chris Leonello
> > [EMAIL PROTECTED]
> >
> >
> >
> > __________________________________
> > Yahoo! Mail - PC Magazine Editors' Choice 2005
> > http://mail.yahoo.com
> > _______________________________________________
> > Zope3-users mailing list
> > Zope3-users@zope.org
> > http://mail.zope.org/mailman/listinfo/zope3-users
> >
> >
> 
> 


Chris Leonello
[EMAIL PROTECTED]


                
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com
_______________________________________________
Zope3-users mailing list
Zope3-users@zope.org
http://mail.zope.org/mailman/listinfo/zope3-users

Reply via email to