You'll want to look into virtualenv:
that should sort out your python versions and plone clashing with Zope 3

Jeffrey D Peterson
Crary Industries, Inc.

-----Original Message-----
From: [] On
Behalf Of Luis Espinoza Jr.
Sent: Wednesday, April 08, 2009 2:54 AM
Subject: [Zope3-Users] new to python-zope-plone and need advice

Good morning from the new guy on the list.

I'm a C++ programmer planing to start my own programming business.

For the web stuff, I'm thinking about using Plone if a CMS is required and
Zope 3 if I don't need a CMS.

I have Windows XP Pro on my desktop. I will probably lease or colocate a
server at a hosting service running OpenBSD or FreeBSD.

Can Plone and Zope 3 co-exist on the same system? Are there problems because
of Zope 2 in Plone clashing with Zope 3? I understand Plone contains some
Zope 3 components and I wonder if I will end up with multiple copies of the
same software.

What about the Python versions? Can I install Python 2.5 or 2.6 and have
Plone and Zope 3 use it, or will each want their own Python?

Finally (for now), to get up to speed on this software I am planning to buy
the following books:

Learning Python
Professional Plone Development
Web Component Development with Zope 3

Am I on the right path or should I run away before it's too late? :)


Quick access to your favorite MSN content and Windows Live with Internet
Explorer 8.
Zope3-users mailing list

Zope3-users mailing list

Reply via email to