On 7/20/13 1:50 AM, Thierry Florac wrote:
> Could you give me your versions of setuptools, distribute and
> zc.buildout ?
> Thierry

Python 2.7.3
ls  /usr/local/lib/python2.7/site-packages/


Anyhow your point is well taken.  The problem is not with ztfy, the
problem is that some of the installation tools changed.

So I took a quick look on pypi.

Buildout just got updated july 5th

Setup tools got updated on the 18th of July.

I first had this problem on July 15th, Tamer on July 16th, so we thought
that buildout had changed.

My guess is that python bootstrap.py downloads the newest version of
buildout, which is what breaks. 

I told this to Tamer, he immediately started reading the source code,
and pointed out the options.  One option was to
use setuptools rather than distribute.  We tried that and it worked.  So
here is the fix.

python bootstrap.py --setuptools

And that does the needful happily for Tamer and myself.

The larger point is that we have multiple versions of things. 
Buildout.cfg manages all of that correctly, but bootstrap.py just grabs
the newest
version of buildout, and so caused trouble. 

It was a very weird bug, where something that was working one week, was
not working the next week.

Maybe I should report that as a bug on zope-dev

I also want to say that it is a huge pleasure working with Thierry and
Tamer.  Thierry pointed us in the right direction, at a high level I
figured out what the problem was, Tamer got into the details of the code
to find out the options.    Much more fun than working alone. 


Zope3-users mailing list

Reply via email to