>> Hm, this is getting hard to answer. Adding normal instances of ZCLasses
>> to other ZClasses should work. Are you adding everything straight from
>> the management interface or programmatically from DTML?
>> If from the management interface, are you sure you always add TinyTable
>> etc from within the instance?
>> If programmatically, could you send the code?
>> Perhaps you could try and adding one of the problem products in another
>> way (from a dtml method instead of the management interface or the other
>> way around).
>The items I'm adding aren't other ZClasses, but rather from python
>I haven't come up with an exhaustive list of which items cause the problem
>and which don't, but I know at least the TinyTable and ZMySQL DB Connection
>do, and the DTML Methods/Documents, MailHost and UserFolders don't.
>Everything is being added via the interface.  I haven't tried adding them
>via DTML.  I've never done that because I haven't had a use for it, so I'm
>not sure I know how.
>I setup a series of screen shots to demonstrate exactly what's happening.
>Take a look at http://www.logicetc.com/Test/zclass_problem if you're

I looked at it, and found it fishy. The strange thing is, I tried to
reproduce it, but I can't. To be sure I added a tiny table plus to an
instance not a straight tiny table and a ZODBC adapter, but I doubt whether
this would make a difference. Anyway, they both work straight away. This is
getting very strange indeed. It seems strange things are happening to your

I can think of some things that may cause problems, but this is all

This may be a bug, but then it's a special one. Anything special about your
ZClass - what does it derive from (just objectmanager? anything else that
might cause strange behaviour?).
Is there a subobjects tab in it's definition? Are the products in there?


Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to