On Fri, 11 Aug 2000, Scott Burton wrote:
> I am trying to run the latest version of Zope (2.2.1 beta) on a Redhat 6.2
> Linux system. When I run the ./start script it gets to the Zope Server
> Monitor and sits there. It never returns back to the bash prompt. I can get
> to Zope's management interface from a browser so Zope *is* running. However
> if I close that terminal window, Zope stops. Python 1.5.2_13 is the version
> installed by Redhat. Which is the correct version of Python, last I
> checked. Also, if I run a startup script to start Zope during the boot
> process, it hangs the boot process. Any suggestions?

Because the start script runs Zope  in Debug mode by default (-D), it does 
not background.  Either run  ./start &   or remove the -D from the start 

Personally, i have added the following line to the end of /etc/rc.d/rc.local :

/bin/su -l zope --command=/usr/local/zope/start &

I have added a user called zope, and 'chown'ed all the zope files to user 
zope group zope.

Alternatively, you CAN run zope from inittab by adding:
zo:234:respawn:/bin/su zope -c /usr/local/zope/start >/dev/msglog2 
<>/dev/msglog </dev/console

This will mean that if, for some bizarre reason, zope crashes (or is killed), 
it will restart.

> Scott Burton

Have a better one,
        Curtis Maloney

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to