Hi Phil,
I have done what you have suggested and Zope start without errors.
I can build a new ZmxODBC connection to a SQL server 7.0, and Zope doesn't
return errors.
Now I tried to browser the DB (that already exists) and I got this Error:

Error Type: InterfaceError
Error Value: SQL type (code -9) not implemented

I tried to make a simple select in a already existent Table
ex: select * from T_TIPO
but the same error occurs

I created some new table with the test query utils in Zope and no error was
presented. I can make select in those new tables.

How is the Problem??

With The ZODBCDA I can browse the DB and all works?

Any Idea?
Any Suggestion?

Thanks Very Much

Paolo Quaglia

> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
> Philipp Auersperg
> Sent: Tuesday, December 12, 2000 12:51 PM
> Subject: Re: [Zope] ODBC Connection
> the ZmxODBC DA uses the Zope-independent product mxODBC, that
> provides a generic
> Python DB API compliant ODBC interface to Python.
> ZmxODBC installs mxODBC into lib/python/Shared/mx. The problem is
> that this path is not in the default PythonPath.
> Solution:
> move the mx directory from lib/python/Shared into a directory
> that's member of PythonPath (for example lib/python).
> phil

Zope maillist  -  [EMAIL PROTECTED]
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://lists.zope.org/mailman/listinfo/zope-dev )

Reply via email to