On May 17, 2005, at 5:17 PM, Tres Seaver wrote:

Perhaps I conflated two memories.  I'm pretty sure that *something* in

the Zope codebase requires zlib, but I take Tim's word for it that I

wrongly attributed that dependency to ZODB.

At one point, our system administration staff commissioned machines in the barest of bare bones fashions, and zlib was one of the things that wasn't installed unless specifically requested. I have had also spent time building python and Zope just to have Zope complain about zlib on startup. There are at least a couple of places that I can think of on the Zope side that require zlib, the HTTP server needs it to handle  "content-encoding: gzip" responses.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to