Tim Peters wrote:
That means the import worked fine -- and it should work fine.  What
happens when you try it?
[Martin Raspe]

I see the same error message that ZOPE gives.

FYI, pasting the exact DOS box input and output (as I did above) saves
the reader from needing to guess at 100 details.

Any solution?

Sorry, not unless someone can give useful information.  If you're
familiar with Python, you should be able to figure out why the import
doesn't work, and tell us the solution.  If you're not familiar with
Python, it will have to wait until someone who is familiar, and can
reproduce the problem (I cannot), does this work.

Sorry, I thought that was clear. It says exactly the same as the ZOPE error message:

Python 2.3.5 (#62, Feb 8 2005, 16:23:02) [MSC v.1200 32 bit (Intel)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> from ZConfig.components.logger import loghandler
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
ImportError: No module named components.logger

But I think I found the error: On Windows, Python seems to prefer information from the Registry to the environment vars. The wrong registry information was left there from a prior Zope/Plone installation. It seems the Zope-2.8.0 Windows installer does not update the registry for Python, so Python takes a wrong import path. I found out by saying
  import ZConfig
and the wrong directory would show up. Removing the old installation solved the problem. Other Zope installations (2.7.4, 2.7.6) were not affected by the left-over registry entries. So I suppose this is a subtle bug in the 2.8.0 Windows installer.


Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to