[Andreas Krasa]
> We are encountering some really strange problems with Zope 2.7.7 on our
> RedHat EL 4 Linux machines.
> During the Zope 2.7.7 compilation works - however most of the time "make
> test" returns a random number of errors (somewhere between 20 and 30)
> ALL related to ZEO.
> The funny thing is, we've managed to do a "make test" without any
> failures - however after doing a "make distclean" and compiling
> everything again "make test" produces the above mentioned errors (using
> *exactly* the same source code!).
> I have absolutely no idea how this can happen - ANY hints are
> appreciated! Is this a known issue?

No.  For example, it doesn't happen in the daily overnight testrunner reports.

> What could it be related to?

ZEO <wink>?  You'll have to give more info about which tests fail, and
precisely how they fail.  Because many of the ZEO tests create
multiple processes, and try to assign sockets so that these processes
can communicate, they're vulnerable to vagaries of OS process
scheduling and socket use by other apps.  For example, on a slow or
overburdened (with other simultaneous work) machine, some ZEO tests
can fail due to not getting enough cycles soon enough.  The worst
tests of that sort wait as long as a minute now for another process to
"do something" they're waiting for before failing, but not even
waiting a minute can _guarantee_ success.

Might be informative to run the tests on an otherwise-quiet machine.
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists -
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to