On Tue, Oct 11, 2005 at 03:42:44AM +1000, Alan Milligan wrote:

> > yes. I I run the script from the ZMI logged in as admin it finds members, 
> > but if I try it from an XMLRPC client it does not
> > 
> You're sure you haven't got an access control problem and that your
> xml-rpc client is not running up as Anonymous?

Yes the client is not loggin in. (and since it will be a commandline 
script it is not supposed to do).

If I hardcode some bogus data to be returned it works fine. But as soon 
as something in the catalog is searched it does not work. So the xmlrpc 
If I run the script from the browser (with default parameters) logged in 
as Manager it works. So the functionality works.

But really searching for something through xmlrpc does not work. If I copy 
& paste the code in an (ZODB) Python script which I give the Authenticated 
proxy role it works perfect.

So I suspect the conclusion is that the external method lacks that proxy 

"Nothing is as subjective as reality"
Reinoud van Leeuwen    [EMAIL PROTECTED]
Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - 
 http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to