I've got a bit more information from my Z2.log:

On a normal startup attempt with data.fs:

I get one or two lines with "HEAD /VirtualHostBase/http/:80/ HTTP/1.1" 200 312 "" "" as the anonymous
Then a GET 200 code (ok) when I authenticate at the /manage URL

On the new storage:
No "HEAD" lines appear as the anonymous user and the first two GETs to the /manage URL give a 500 code (internal server error)

The following error appears on the browser:
Error Type: TypeError
Error Value: unbound method method_descriptor object must be called with Application instance as first argument (got RequestContainer instance instead)

The third GET always succeeds (200 ok) in allowing authentication. The instance behaves as normal in every regard afterwards.
This only occurs on startup.

Regards,
David






David Pratt wrote:
Hi. I have been experimenting with making a hybrid storage for zodb. The storage seems to work well except that I am getting this error on the first request to the server and I am not exactly sure where it is coming from.

Error Type: TypeError
Error Value: unbound method method_descriptor object must be called with Application instance as first argument (got RequestContainer instance instead)

When I refresh the browser, I get my login and no problems at all using the zope instance etc. The event and error logs are clean. But when I restart the server, the error appears on startup again. Many thanks.

Regards,
David
_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

_______________________________________________
Zope maillist  -  Zope@zope.org
http://mail.zope.org/mailman/listinfo/zope
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to