Hi there!

I am trying right now to convince people to use buildout and ZCA for the Open Grid Protocol project but it turns out that it's not working as expected. So maybe somebody on here can help me :-)

The setup is Mac OSX 10.5.4 with Python 2.5.1 installed and apparently a zope.interface egg inside the standard install of Python of version 3.3.0. (you can see the contents of the lib dir her: http://pastebin.com/d3f5fb455)

On some machines it now seems that this version is used instead of using a newer one the system wide installed one is used (for some reason not on my own machine), so the for instance the testrunner script looks like this: http://pastebin.com/d1a1024d2

(as you can see the standard lib is put into the path but not a separate zope.interface egg).

The problem it comes down to when running buildout is the following: http://pastebin.com/d1ec846fa

The important lines are probably:

File "/Users/tess/pyogp/eggs/zope.security-3.5.1-py2.5-macosx-10.5-i386.egg/zope/security/interfaces.py", line 20, in <module>
from zope.interface.common.interfaces import IException, IAttributeError
File "/System/Library/Frameworks/Python.framework/Versions/2.5/Extras/lib/python/zope/interface/common/interfaces.py", line 80, in <module>
    classImplements(OverflowWarning, IOverflowWarning)
ZopeXMLConfigurationError: File "/Users/tess/pyogp/src/pyogp.lib.base/pyogp/lib/base/configure.zcml", line 6.2-6.55
ZopeXMLConfigurationError: File "/Users/tess/pyogp/eggs/zope.component-3.4.0-py2.5.egg/zope/component/meta.zcml", line 7.4-11.10
    NameError: name 'OverflowWarning' is not defined

So zope.component 3.4.0 probably needs zope.interface 3.4.x but installed is 3.3.0.

Now my question is: How can I solve this problem. I think I tried to put zope.interface>=3.4 into all sorts of places but one outcomes only seemed to be a version conflict saying that 3.3.0 is installed already
(unfortunately I also cannot test this myself as in my case it's working).

Here is the buildout.cfg: http://svn.secondlife.com/svn/linden/projects/2008/pyogp/buildouts/libdev_mac/trunk/buildout.cfg

There also is a setup.py which contains the following dependencies:

          # -*- Extra requirements: -*-
          'zope.component [zcml]',



And you can find the whole buildout here:

(this is a special version which only runs with Python2.5 and installed a development version of setuptools which I bundled with it because of the problems with subversion 1.5. I suspect though that it also fixed some other bugs as people here constantly seemed to have problems with buildout which now seems to be reason enough to move away from buildout and the Zope Component Architecture).

Hope somebody can help :-)



Christian Scholz                         video blog: http://comlounge.tv
COM.lounge                                   blog: http://mrtopf.de/blog
Luetticher Strasse 10                                    Skype: HerrTopf
52064 Aachen                              Homepage: http://comlounge.net
Tel: +49 241 400 730 0                           E-Mail [EMAIL PROTECTED]
Fax: +49 241 979 00 850                               IRC: MrTopf, Tao_T

neue Show: TOPFtäglich (http://mrtopf.de/blog/category/topf-taglich/)

Zope maillist  -  Zope@zope.org
**   No cross posts or HTML encoding!  **
(Related lists - http://mail.zope.org/mailman/listinfo/zope-announce
http://mail.zope.org/mailman/listinfo/zope-dev )

Reply via email to