The doc could well be a bit wrong in step 2 - please file a bug for that :)

I do use it successfully with the following script to start it though:

PLEXUS_BASE=$HOME/Library/Application\ Support/Archiva

No modifications to the installation are needed.

Maybe you were missing an export of PLEXUS_BASE before starting? (the
above doesn't need it since it's all on one line, the env vars are
passed to the second run script).


On 18/02/2008, Martin Hoeller <[EMAIL PROTECTED]> wrote:
> Hi!
> I'm trying to install archiva 1.0.1 on Linux as a standalone application
> as running in JBoss gives various errors.
> The archiva admin guide for standalone installation [0] says
> | However, the best way to use this installation technique is to separate
> | the configuration from the installation to make it easy to upgrade to
> | newer versions in the future.
> I tried to follow these steps exactly as explained. However, it seems this
> does not work at all.
> First, there is no 'data'-directory as mentioned in step 2 (I ignored
> this for now).
> Second, as archiva should now hold it's data in the PLEXUS_BASE
> directory, I thought it shouldn't need to write to the installation
> directory (PLEXUS_HOME) which seems not to be true. If write access to
> the PLEXUS_HOME directory is denied archiva startup fails. So I granted
> write permissions to this directory.
> Third, the user- and artifact- database seem to be created in the
> installation base (PLEXUS_HOME) and not PLEXUS_BASE, as PLEXUS_HOME now
> contains new directories data/archiva and data/users with lots of files
> in it.
> Has anybody successfully tried to perform a separation of installation
> and data in archiva 1.0.1?
> Any comments are welcome.
> tia,
> - martin
> [0]
> --
> Martin Höller                   | [EMAIL PROTECTED]
> *x Software + Systeme           |
> Karmarschgasse 51/2/20          | Tel: +43-1-6060114-30
> A-1100 Vienna, Austria          | Fax: +43-1-6060114-71

Brett Porter

Reply via email to