Thanks for the diligent feedback.


Going through the notes makes make stumble upon this:
Added a new 'parser.allows.dash.in.identifiers' boolean property (false per default) to (dis)allow '-' in reference identifiers . Fixes VELOCITY-542.

I see a few issues here:
* The property name is awkward. Where is the hierarchy? Shouldn't it rather be 'parser.allow_dash_in_identifiers'? (Applies to VELOCITY-904 too). * '-' U+002D is *not* a dash. It is a hyphen (minus). A lot of people get and do it wrong. I would strongly recommend to fix that typographic issue /before/ 2.1.

So the new property should be named "parser.allow_hyphen_in_identifiers".

Looking at the current state of our runtime properties names, I see that there are many inconsistencies:

 - '.' is used many times as a word separator instead of a hierarchical separator  - sometimes there is no word separator at all, as in "resource.manager.logwhenfound"  - sometimes we use CamelCase, as in "resource.loader.modificationCheckInterval"

Maybe it's time to homogenize all this. Old property names will of course still be available via a deprecation mechanism.

Any preference between underscore_word_separator and CamelCase?

Other issues:
* "Fix parsing of a terminal hash or dollar sign in sing litteral and template" should rather be "...sign literal..."? * *The minimum JDK is now 1.8*: This should have been a separate issue and stated right on the front page for our users instead of being a side note.

Very true.


  Claude


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscr...@velocity.apache.org
For additional commands, e-mail: dev-h...@velocity.apache.org

Reply via email to