[Brendan J Simon]
> > Either if_dep, else_dep and end_dep _or ifdep, elsedep, enddep.

I like it.  My original if_dep was ifdep, but I thought people would
mistake it for the common verb 'ifdef' and misspell it that way.  So I
vote for the _s.

[Greg Banks]
> Yes, the _s should be consistent.  How about using "fi" instead of
> "end" for consistency with the current scheme?

Hmmmm, not sure - the point is to get *away* from shell syntax.  OTOH,
somehow fi_dep *does* seem more consistent than end_dep.

else_dep() is a simple matter of reversing the polarity of the guard.
Basically:

  function else_dep () {
        case "$nest_ifdef" in
          '') {{{ syntax error: else without if }}} ;;
          y|m) nest_ifdef=n ;;
          n) nest_ifdef=y ;;
        esac
  }

I suppose Bourne-feature-completeness would demand 'elif_dep' as well.
That's not hard either, but is it overkill?  I know Linus hates
overengineering, and to a much lesser extent so do I.

Peter


-------------------------------------------------------
This sf.net email is sponsored by: OSDN - Tired of that same old
cell phone?  Get a new here for FREE!
https://www.inphonic.com/r.asp?r=sourceforge1&refcode1=vs3390
_______________________________________________
kbuild-devel mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/kbuild-devel

Reply via email to