[Giacomo A. Catenazzi]
> I don't like calling it "or"... It is error prone because it is a non 
> binary system,
> thus can confuse the lazy developers.

I had to call it something.  I for one think 'or' is quite intuitive
here.  If you insist that OR can only be done on binary values, think
of 'y'==3 and 'm'==1.

> Better "min".

You mean "max".  "min" would in this case be a logical AND.  But
nobody thinks of "max" as an infix operator, and infix is IMO the most
natural way to express a low-precedence operator without explicit
grouping.

> Also I don't like the construct if_dep that parse multiple lines.
> IMHO better a single line statment:
> if_dep ..cond.. then ..cml1_statment..

My goal here is to replace the current 'if' statement.  I think the
current syntax is ugly and looks too much like Bourne shell (which of
course is not a coincidence).

As such, a multi-line construct is necessary.  There are some passages
of kernel Config.in files that have 20 or 30 lines under a single
conditional.  Changing those to be line-by-line is not really an
option.

Peter


-------------------------------------------------------
This sf.net email is sponsored by: OSDN - Tired of that same old
cell phone?  Get a new here for FREE!
https://www.inphonic.com/r.asp?r=sourceforge1&refcode1=vs3390
_______________________________________________
kbuild-devel mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/kbuild-devel

Reply via email to