On Tuesday 04 April 2017 17:12:37 Jon Foster wrote:
> Martin,
> Per your request in the discussion we were having in the fpGUI news groups
> about the "need" for form files and streaming form layouts I will detail
> what I remember of my trial runs of recent MSEgui versions. I used 4.4
> (4.4.1 I think) and 3.8.8. 4.4.x worked better in the visuals department.
> The problems I ran into fall roughly in three categories:

Which operating system/window manager?
Can you try again with current git master version:
so we can sort out the problems?
Please compile MSEide in clone-directory with
fpc -Fulib/common/* -Fulib/common/kernel/linux apps/ide/mseide.pas

> 1. Z-Ordering problems: Forms falling / rising unexpectedly. The worst
> example was clicking a menu item and a background window, not even from the
> MSEide, was pulled up behind the drop down menu, obscuring, among other
> things, the window the menu was attached to.
Maybe a window manager with buggy NET_RESTACK_WINDOW protocol handling. 
Starting MSEgui applications with --NORESTACKWINDOW activates a workaround, 

> 2. Form content disappearing. Particularly with the 3.x version using the
> arrow keys to move up and down in the inspector caused values for other
> properties to disappear and then re-appear... seemingly at random. I think
> its tied to the value editor for the property that gets the focus.
That looks similar like an effect of a buggy RADEON driver
Switching off EXAPIXMAPS helps, see README.TXT.

> 3. Won't connect to MySQL: In 3.x I'd get an "Access Violation" after
> setting the properties and then setting the "connected" property to true.
> In 4.x it would report an authentication failure. I retyped my password,
> double checked the host, user and DB names several times before I realized
> the the error message said I wasn't allowed access to a database that
> doesn't exist. What is apparently happening is the DB name is truncated to
> just the first character. I had two test databases: "logging" and "foster".
> So the error message would say I was denied access to "f" or "l", depending
> on which I tried.
That should already been fixed.
A heavy regression, sorry.

> I believe I also saw "failure to redraw when exposed" issues.
Again looks like the EXA-problem.

> Its been a few weeks since I tried to use it so the details are a bit
> fuzzy. And I know I saw other "drawing" defects. Bottom line is I didn't
> want to /inherit/ the drawing / user nuisance issues and DB based apps is
> the primary use I have for MSEgui, so not being able to connect to a DB was
> end of game for me. If the rest of the IDE had functioned I would have
> moved onto trying to build for ZEOS, since I saw you have instructions on
> doing that and that is what I use to bring some sanity to Lazarus.

I suggest to use the native MSEgui DB-components, they have the best 
integration into the MSEgui environment.

> I'm also 
> aware of how difficult it is to target MySQL due to the ongoing idiocy in
> the way they routinely mangle their client library. I have my own
> light-weight MySQL interface that I've maintained since MySQL 3.28. After 3
> or 4 client changes I just carry around the lib version that I last updated
> for and install it on the client machines.
TmseMySQLConnection should work with all versions from 5.0 upwards.

> Any thoughts on use on OS X? Last I asked I was told, "why would I want
> to?" And the answer is, "'cause I want to write once run everywhere." Isn't
> that what we all want?

IIRC I answered that Mac people probably will not accept anything which is not 
110% Apple. ;-)
OSX support can be done if there is enough interrest and/or a sponsor. Because 
Apple tries to lock out alien systems it will not be easy I fear.


Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
mseide-msegui-talk mailing list

Reply via email to