Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Luc Maisonobe
Le 30/06/2013 23:57, Thomas Neidhart a écrit : > Hi, > > I'd like to call a vote for releasing Commons Collections 4.0-alpha1 > based on RC2. > > The following changes have been applied since RC1: > > * upgrade to maven-javadoc-plugin 2.9.1 (due to CVE-2013-1571) > * fixed COLLECTIONS-474, tha

Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Olivier Lamy
2013/7/1 Thomas Neidhart : > Hi, > > I'd like to call a vote for releasing Commons Collections 4.0-alpha1 > based on RC2. > > The following changes have been applied since RC1: > > * upgrade to maven-javadoc-plugin 2.9.1 (due to CVE-2013-1571) > * fixed COLLECTIONS-474, thanks to sebb > * fixed

[RESULT][VOTE][LAZY] Release Commons Parent 32 from RC1

2013-07-01 Thread sebb
The 72 hours having elapsed without any -1 votes having been cast, the vote duly passes. On 28 June 2013 13:18, sebb wrote: > This is a VOTE to release Commons Parent 31-RC2 > > This VOTE by LAZY-CONSENSUS is open for at least 72 hours > It will finish no earlier than July 1 2013 at 14:00 GMT. >

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Gilles
Hi. I just noticed your request to write the algorithm along the lines of the wikipedia article. The only major difference between my code and the article on Wikipedia is that I found it necessary to move the recursive stack in into a data structure to avoid a StackOverflowException when t

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Ajo Fod
If you wanted to use the Math 3 codebase in AdaptiveQuadrature, you'd compute the calculations of Q1 and Q2 with something else. I'm not entirely familiar with the apache Math codebase so my guess would be that you can replace the following line in AdaptiveQuadrature.proc(): double Q1 = delta / 6

[collection] v4 CompliantBag

2013-07-01 Thread Gary Gregory
Hi All: I find the class name CompliantBag pretty confusing. Compliant with what? The Javadoc says Collection so, why not call it BagCollection? Gary -- E-Mail: garydgreg...@gmail.com | ggreg...@apache.org Java Persistence with Hibernate, Second Edition JUnit in

Re: [collection] v4 CompliantBag

2013-07-01 Thread Emmanuel Bourg
Le 01/07/2013 21:06, Gary Gregory a écrit : > I find the class name CompliantBag pretty confusing. Compliant with what? > The Javadoc says Collection so, why not call it BagCollection? +1 Emmanuel Bourg - To unsubscribe, e-m

Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Oliver Heger
+1 Oliver Am 30.06.2013 23:57, schrieb Thomas Neidhart: Hi, I'd like to call a vote for releasing Commons Collections 4.0-alpha1 based on RC2. The following changes have been applied since RC1: * upgrade to maven-javadoc-plugin 2.9.1 (due to CVE-2013-1571) * fixed COLLECTIONS-474, thanks

Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Benedikt Ritter
Hello Thomas, first of all: many thanks for the great effort you put into collections. I think aside from math and lang, collections is probably one of the most used components. It's really cool to see this happening. So here is my vote: - Checksums and signatures are okay. - Site looks good, but

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Konstantin Berlin
Just a few thoughts. It seems to me that this code suffers from redundant function evaluations. I am not sure what to think about the movement from edges since it violates proper behavior for well behaved functions in order to work for some special cases. In case of infinite integrals it might

[ANNOUNCE] Commons Parent 32 released

2013-07-01 Thread sebb
Commons Parent 32 has been released. The only change is to update the Javadoc plugin to 2.9.1 to address the Javadoc script vulnerability. Components are recommended to upgrade before the next release as this release fixes the Javadoc issue. If the component cannot be upgraded immediately (not su

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Ajo Fod
1> Could you provide an example of redundant function evaluations in my code? 2> I made the adjustment in AQ because the size of the segment that was excluded from the integration could be determined adaptively to keep the error arbitrarily low. Note the size of the segment that is excluded (at th

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Gilles
Hi. On Mon, 1 Jul 2013 10:50:19 -0700, Ajo Fod wrote: If you wanted to use the Math 3 codebase in AdaptiveQuadrature, you'd compute the calculations of Q1 and Q2 with something else. I'm not entirely familiar with the apache Math codebase [...] You could file a "wish" request as a Commons Ma

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Konstantin Berlin
private void proc(UnivariateFunction fn) { +Calc calc = calcs.pop();// pop a calculation to be done. +double a = calc.a; +double b = calc.b; + +// back off slightly from the edges (function evaluations typically go haywire) +// scale for the edge a

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Ajo Fod
Hi Gilles, Your accuracy concern made me wonder. So, I dropped the AdaptiveQuadrature.EPS to 1e-2 from 1e-9 in the code and ran the test in the patch. I computed the log of the error per evaluation ...i.e a measure of the efficiency of the algorithm. And wait for it ... AQ beats LGQ by about 5% f

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Konstantin Berlin
I am not understanding the discussion here. Adaptive integration is designed for functions that have different behavior in different regions. Some regions are smoother, some have higher frequeniesy. How you integrate a divided region, Simpson rule or whatever is a separate question. Adaptive integ

Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Anshul Zunke
Do we have 2 way hashmap in collections? If not i think we shuld have it On Tue, Jul 2, 2013 at 1:24 AM, Oliver Heger wrote: > +1 > > Oliver > > Am 30.06.2013 23:57, schrieb Thomas Neidhart: > >> Hi, >> >> I'd like to call a vote for releasing Commons Collections 4.0-alpha1 >> based on RC2. >> >

Re: [math] On MATH-995: Problems with LegendreGaussQuadrature class.

2013-07-01 Thread Ajo Fod
Hi Konstantin, Thanks for pointing out the inefficiency in AQ. I just improved the efficiency of AQ to 1.41x that of LGQ (up from 1.05x) - measured in digits of accuracy per evaluation for integral of normal with sigma 1000 in range [-5000, 5000] Please let me know if this doesn't answer your que

Re: [VOTE] Release of Commons Collections 4.0-alpha1 based on RC2

2013-07-01 Thread Gary Gregory
+1 Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 08:51:28-0500) Maven home: C:\Java\apache-maven-3.0.5\bin\.. Java version: 1.7.0_25, vendor: Oracle Corporation Java home: C:\Program Files\Java\jdk1.7.0_25\jre Default locale: en_US, platform encoding: Cp1252 OS name: "w

Re: [collection] v4 CompliantBag

2013-07-01 Thread Thomas Neidhart
On 07/01/2013 09:06 PM, Gary Gregory wrote: > Hi All: > > I find the class name CompliantBag pretty confusing. Compliant with what? > The Javadoc says Collection so, why not call it BagCollection? I agree that CompliantBag is not a very good choice, but the notation in collections was to name dec