Re: [PATCH 1/7] Makefile, LLVM: add -no-integrated-as to KBUILD_[AC]FLAGS

2017-04-21 Thread Masahiro Yamada
Hi Michael, 2017-03-17 9:15 GMT+09:00 Michael Davidson : > Add -no-integrated-as to KBUILD_AFLAGS and KBUILD_CFLAGS > for clang. >From the code-diff, it is apparent that you added -no-integrated-as. Rather, I'd like to see "why" in the git-log. Obviously, clang needs this

[cpu/hotplug] d215aab82d: [ INFO: possible circular locking dependency detected ]

2017-04-21 Thread kernel test robot
Greetings, 0day kernel testing robot got the below dmesg and the first bad commit is https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git smp/hotplug commit d215aab82d81974f438bfbc80aa437132f3c37c3 Author: Thomas Gleixner AuthorDate: Tue Apr 18 19:05:06 2017

Re: [PATCH v2 2/3] crypto: inside-secure: add SafeXcel EIP197 crypto engine driver

2017-04-21 Thread Antoine Tenart
Hi Corentin, On Fri, Apr 21, 2017 at 09:30:56AM +0200, Corentin Labbe wrote: > > I have some minor comment below […] > > + /* > > +* Result Descriptor Ring prepare > > +*/ > > This is not preferred comment format for one line Sure. > > [...] > > > +static int

Re: [PATCH v2 2/3] crypto: inside-secure: add SafeXcel EIP197 crypto engine driver

2017-04-21 Thread Corentin Labbe
Hello I have some minor comment below On Wed, Apr 19, 2017 at 09:14:17AM +0200, Antoine Tenart wrote: > Add support for Inside Secure SafeXcel EIP197 cryptographic engine, > which can be found on Marvell Armada 7k and 8k boards. This driver > currently implements: ecb(aes), cbc(aes), sha1,

[PATCH] crypto: Allow ecb(cipher_null) in FIPS mode

2017-04-21 Thread Milan Broz
The cipher_null is not a real cipher, FIPS mode should not restrict its use. It is used for several tests (for example in cryptsetup testsuite) and also temporarily for reencryption of not yet encrypted device in cryptsetup-reencrypt tool. Problem is easily reproducible with cryptsetup

[PATCH] crypto: crypto4xx: rename ce_ring_contol to ce_ring_control

2017-04-21 Thread Colin King
From: Colin Ian King trivial spelling mistake, missing r, rename to ce_ring_control Signed-off-by: Colin Ian King --- drivers/crypto/amcc/crypto4xx_core.c| 2 +- drivers/crypto/amcc/crypto4xx_reg_def.h | 2 +- 2 files changed, 2

Re: [PATCH 2/2] crypto: acomp - add support for deflate rfc1950 (zlib)

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 03:11:42PM +0100, Giovanni Cabiddu wrote: > > +}, { > + .alloc_ctx = zlib_deflate_alloc_ctx, > + .free_ctx = deflate_free_ctx, > + .compress = deflate_scompress, > + .decompress = deflate_sdecompress, > +

Re: [PATCH v2 2/3] crypto: inside-secure: add SafeXcel EIP197 crypto engine driver

2017-04-21 Thread Antoine Tenart
On Fri, Apr 21, 2017 at 01:36:45PM +0200, Corentin Labbe wrote: > > > > + memset(ipad + keylen, 0, blocksize - keylen); > > > > + memcpy(opad, ipad, blocksize); > > > > + > > > > + for (i = 0; i < blocksize; i++) { > > > > + ipad[i] ^= 0x36; > > > > +

Re: [PATCH] crypto: Allow ecb(cipher_null) in FIPS mode

2017-04-21 Thread Herbert Xu
Milan Broz wrote: > The cipher_null is not a real cipher, FIPS mode should not restrict its use. > > It is used for several tests (for example in cryptsetup testsuite) and also > temporarily for reencryption of not yet encrypted device in > cryptsetup-reencrypt tool. > >

Re: [PATCH] crypto: acomp - report scomp implementations

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 02:26:14PM +0100, Giovanni Cabiddu wrote: > Fix crypto_has_acomp to report scomp implementations. > > Signed-off-by: Giovanni Cabiddu > --- > include/crypto/acompress.h | 1 + > 1 file changed, 1 insertion(+) > > diff --git

Re: [PATCH 2/2] n2rng: Combine substrings for two messages in n2rng_probe()

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 11:11:35AM +0200, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 19 Apr 2017 10:50:04 +0200 > > The script "checkpatch.pl" pointed information out like the following. > > WARNING: quoted string split across lines > > Thus fix

Re: [PATCH] crypto: algif_aead - Require setkey before accept(2)

2017-04-21 Thread Herbert Xu
On Mon, Apr 10, 2017 at 01:59:21PM +0200, Stephan Müller wrote: > > @@ -757,12 +887,14 @@ static void aead_sock_destruct(struct sock *sk) > af_alg_release_parent(sk); > } > > -static int aead_accept_parent(void *private, struct sock *sk) > +static int aead_accept_parent_nokey(void

Re: [PATCH v2 2/3] crypto: inside-secure: add SafeXcel EIP197 crypto engine driver

2017-04-21 Thread Corentin Labbe
> > > + memset(ipad + keylen, 0, blocksize - keylen); > > > + memcpy(opad, ipad, blocksize); > > > + > > > + for (i = 0; i < blocksize; i++) { > > > + ipad[i] ^= 0x36; > > > + opad[i] ^= 0x5c; > > > > What are these constant ? > > They are defined in the HMAC RFC, as ipad and

Re: [PATCH] crypto: acomp - replace compression known answer test

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 02:27:18PM +0100, Giovanni Cabiddu wrote: > Compression implementations might return valid outputs that > do not match what specified in the test vectors. > For this reason, the testmgr might report that a compression > implementation failed the test even if the data

Re: [PATCH v5 0/2] crypto: hw_random - Add new Exynos RNG driver

2017-04-21 Thread Herbert Xu
On Tue, Apr 11, 2017 at 08:08:33PM +0200, Krzysztof Kozlowski wrote: > Hi, > > This is a follow up of my questions around exynos-rng [1]. > > Changes since v4: > = > 1. Patch 2/2: Use "stdrng" name, as suggested by Herbert. > 2. Patch 2/2: Add Bartlomiej's reviewed-by. All

Re: [PATCH] crypto: acomp - allow registration of multiple acomps

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 02:23:05PM +0100, Giovanni Cabiddu wrote: > Add crypto_register_acomps and crypto_unregister_acomps to allow > the registration of multiple implementations with one call. > > Signed-off-by: Giovanni Cabiddu Patch applied. Thanks. -- Email:

Re: [PATCH v2] powerpc/crypto/crct10dif-vpmsum: Fix missing preempt_disable()

2017-04-21 Thread Herbert Xu
On Thu, Apr 20, 2017 at 03:35:09PM +1000, Michael Ellerman wrote: > In crct10dif_vpmsum() we call enable_kernel_altivec() without first > disabling preemption, which is not allowed. > > It used to be sufficient just to call pagefault_disable(), because that > also disabled preemption. But the two

Re: [PATCH V3 0/2] Interrupt management fixes

2017-04-21 Thread Herbert Xu
On Thu, Apr 20, 2017 at 03:24:00PM -0500, Gary R Hook wrote: > Correct the driver to attend to only relevant interrupt > bits, and ensure that interrupts are managed properly > at module unload. > > Changes from V2: > - Apply patches to relevant stable branches All applied. Thanks. -- Email:

Re: [PATCH v2 0/2] hwrng: mtk: add support for hardware random generator on MT7623 SoC

2017-04-21 Thread Herbert Xu
On Fri, Apr 21, 2017 at 12:24:24AM +0800, sean.w...@mediatek.com wrote: > From: Sean Wang > > This patchset introduces support for Mediatek hardware random generator (RNG) > Currently, the driver is already tested successfully with rng-tools on MT7623 > SoC. And it should

[PATCH v3 15/29] x86: assembly, annotate aliases

2017-04-21 Thread Jiri Slaby
_key_expansion_128 is an alias to _key_expansion_256a, __memcpy to memcpy, xen_syscall32_target to xen_sysenter_target, and so on. Annotate them all using the new SYM_FUNC_START_ALIAS, SYM_FUNC_START_LOCAL_ALIAS, and SYM_FUNC_END_ALIAS. This will make the tools generating the debuginfo happy.

Re: [PATCH 0/4] Bug fixes and fallback for AEAD

2017-04-21 Thread Herbert Xu
On Mon, Apr 10, 2017 at 06:23:57PM +0530, Harsh Jain wrote: > This series based on Herbert cryptodev-2.6. > It includes bug fixes and fallback for AEAD algos. > > Harsh Jain (3): > chcr: Increase priority of AEAD algos. > chcr:Set hmac_ctrl bit to use HW register HMAC_CFG[456]. > chcr: Add

Re: [PATCH -next] crypto: caam - fix error return code in caam_qi_init()

2017-04-21 Thread Herbert Xu
On Tue, Apr 11, 2017 at 04:04:09PM +, Wei Yongjun wrote: > From: Wei Yongjun > > Fix to return error code -ENOMEM from the kmem_cache_create() error > handling case instead of 0(err is 0 here), as done elsewhere in this > function. > > Fixes: 67c2315def06 ("crypto:

Re: [PATCH 1/2] n2rng: Use devm_kcalloc() in n2rng_probe()

2017-04-21 Thread Herbert Xu
On Wed, Apr 19, 2017 at 11:10:07AM +0200, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 19 Apr 2017 10:30:47 +0200 > > * A multiplication for the size determination of a memory allocation > indicated that an array data structure should be

Re: [PATCH 3/6] ima: Simplify policy_func_show.

2017-04-21 Thread Mimi Zohar
On Thu, 2017-04-20 at 17:40 -0300, Thiago Jung Bauermann wrote: > Am Donnerstag, 20. April 2017, 08:13:23 BRT schrieb Mimi Zohar: > > On Tue, 2017-04-18 at 17:17 -0300, Thiago Jung Bauermann wrote: > > > If the func_tokens array uses the same indices as enum ima_hooks, > > > policy_func_show can

Re: [PATCH v2] crypto: chcr - Fix error handling related to 'chcr_alloc_shash'

2017-04-21 Thread Herbert Xu
On Thu, Apr 13, 2017 at 08:25:15PM +0200, Christophe JAILLET wrote: > Up to now, 'crypto_alloc_shash()' may return a valid pointer, an error > pointer or NULL (in case of invalid parameter) > Update it to always return an error pointer in case of error. It now > returns ERR_PTR(-EINVAL) instead of

[PATCH v3 27/29] x86_32: assembly, change all ENTRY to SYM_FUNC_START

2017-04-21 Thread Jiri Slaby
These are all functions which are invoked from elsewhere, so we annotate them as global using the new SYM_FUNC_START (and their ENDPROC's by SYM_FUNC_END.) Signed-off-by: Jiri Slaby Cc: "H. Peter Anvin" Cc: Thomas Gleixner Cc: Ingo Molnar

[PATCH v3 26/29] x86_64: assembly, change all ENTRY to SYM_FUNC_START

2017-04-21 Thread Jiri Slaby
These are all functions which are invoked from elsewhere, so we annotate them as global using the new SYM_FUNC_START (and their ENDPROC's by SYM_FUNC_END.) And make sure ENTRY/ENDPROC is not defined on X86_64. Signed-off-by: Jiri Slaby Cc: "H. Peter Anvin" Cc:

[PATCH v3 13/29] x86: crypto, annotate local functions

2017-04-21 Thread Jiri Slaby
Use the newly added SYM_FUNC_START_LOCAL to annotate starts of all functions which do not have ".globl" annotation, but their ends are annotated by ENDPROC. This is needed to balance ENDPROC for tools that are about to generate debuginfo. We also convert their ENDPROCs to the new SYM_FUNC_END.

Re: [PATCH] crypto: algif_aead - Require setkey before accept(2)

2017-04-21 Thread Stephan Müller
Am Freitag, 21. April 2017, 13:11:27 CEST schrieb Herbert Xu: Hi Herbert, > On Mon, Apr 10, 2017 at 01:59:21PM +0200, Stephan Müller wrote: > > @@ -757,12 +887,14 @@ static void aead_sock_destruct(struct sock *sk) > > > > af_alg_release_parent(sk); > > > > } > > > > -static int

Re: [RFC PATCH v1 1/1] crypto: algif_compression - User-space interface for compression

2017-04-21 Thread abed mohammad kamaluddin
On Fri, Apr 21, 2017 at 9:20 PM, Stephan Müller wrote: > Am Freitag, 21. April 2017, 17:42:10 CEST schrieb abed mohammad kamaluddin: > > Just diff the just RFCed algif_kpp with the proposed patch set for > algif_skcipher and algif_aead. There you will see that 80% of all code

[PATCH 2/2] crypto: ccp - Change ISR handler method for a v5 CCP

2017-04-21 Thread Gary R Hook
The CCP has the ability to perform several operations simultaneously, but only one interrupt. When implemented as a PCI device and using MSI-X/MSI interrupts, use a tasklet model to service interrupts. By disabling and enabling interrupts from the CCP, coupled with the queuing that tasklets

[PATCH 0/2] Change CCP ISR handler model

2017-04-21 Thread Gary R Hook
he CCP has the ability to perform several operations simultaneously, but only one interrupt. The current design exposes a window when using MSI/MSI-X interrupts wherein state can change but no interrupt is generated; this can lead to a hang in the engine. Switch to a tasklet backend which allows

Re: [PATCH] crypto: Allow ecb(cipher_null) in FIPS mode

2017-04-21 Thread Stephan Müller
Am Freitag, 21. April 2017, 14:18:20 CEST schrieb Herbert Xu: Hi Herbert, > Milan Broz wrote: > > The cipher_null is not a real cipher, FIPS mode should not restrict its > > use. > > > > It is used for several tests (for example in cryptsetup testsuite) and > > also > >

Re: [PATCH 2/2] n2rng: Combine substrings for two messages in n2rng_probe()

2017-04-21 Thread Joe Perches
On Fri, 2017-04-21 at 19:36 +0800, Herbert Xu wrote: > On Wed, Apr 19, 2017 at 11:11:35AM +0200, SF Markus Elfring wrote: > > From: Markus Elfring > > Date: Wed, 19 Apr 2017 10:50:04 +0200 > > > > The script "checkpatch.pl" pointed information out like the

Re: [RFC PATCH v1 1/1] crypto: algif_compression - User-space interface for compression

2017-04-21 Thread abed mohammad kamaluddin
Hi Stephan, On Tue, Apr 18, 2017 at 3:42 PM, Stephan Müller wrote: > Am Donnerstag, 13. April 2017, 20:34:54 CEST schrieb Abed Kamaluddin: > > May I propose that you look into the patches for skcipher and aead regarding > memory handling updates that are currently discussed.

Re: [PATCH] crypto: Allow ecb(cipher_null) in FIPS mode

2017-04-21 Thread Stephan Müller
Am Freitag, 21. April 2017, 17:25:41 CEST schrieb Stephan Müller: Hi, > > Acked-by: Stephan Müller Just for the records: for FIPS 140-2 rules, cipher_null is to be interpreted as a memcpy on SGLs. Thus it is no cipher even though it sounds like one. cipher_null is also

[PATCH v2 2/2] crypto: scomp - add support for deflate rfc1950 (zlib)

2017-04-21 Thread Giovanni Cabiddu
Add scomp backend for zlib-deflate compression algorithm. This backend outputs data using the format defined in rfc1950 (raw deflate surrounded by zlib header and footer). Signed-off-by: Giovanni Cabiddu --- crypto/deflate.c | 61

[PATCH v2 1/2] crypto: scomp - allow registration of multiple scomps

2017-04-21 Thread Giovanni Cabiddu
Add crypto_register_scomps and crypto_unregister_scomps to allow the registration of multiple implementations with one call. Signed-off-by: Giovanni Cabiddu --- crypto/scompress.c | 29 +

Re: [RFC PATCH v1 1/1] crypto: algif_compression - User-space interface for compression

2017-04-21 Thread Stephan Müller
Am Freitag, 21. April 2017, 17:42:10 CEST schrieb abed mohammad kamaluddin: Hi abed, > Hi Stephan, > > On Tue, Apr 18, 2017 at 3:42 PM, Stephan Müller wrote: > > Am Donnerstag, 13. April 2017, 20:34:54 CEST schrieb Abed Kamaluddin: > > > > May I propose that you look into

Re: [PATCH 2/2] n2rng: Combine substrings for two messages in n2rng_probe()

2017-04-21 Thread David Miller
From: Herbert Xu Date: Fri, 21 Apr 2017 19:36:41 +0800 > On Wed, Apr 19, 2017 at 11:11:35AM +0200, SF Markus Elfring wrote: >> From: Markus Elfring >> Date: Wed, 19 Apr 2017 10:50:04 +0200 >> >> The script "checkpatch.pl" pointed

Re: [PATCH] crypto: algif_aead - Require setkey before accept(2)

2017-04-21 Thread Stephan Müller
Am Freitag, 21. April 2017, 13:11:27 CEST schrieb Herbert Xu: Hi Herbert, > Please don't mix unrelated cleanups like this with the real change. > It makes reviewing harder than necessary. Apologies. I will resend it shortly. Ciao Stephan