On Mon 31.Aug'09 at 10:32:31 +0800, Paul Harris wrote:
> 2009/8/31 Carlos R. Mafra <[email protected]>
>
> snip
>
>
> > /* window */
> > -#define WKBD_RAISE 15
> > -#define WKBD_LOWER 16
> > -#define WKBD_RAISELOWER 17
> > -#define WKBD_MOVERESIZE 18
> > -#define WKBD_SHADE 19
> > +#define WKBD_RAISE 16
> > +#define WKBD_LOWER 17
> > +#define WKBD_RAISELOWER 18
> > +#define WKBD_MOVERESIZE 19
> > +#define WKBD_SHADE 20
> > /* window, menu */
> > -#define WKBD_CLOSE 20
> > +#define WKBD_CLOSE 21
> >
>
>
> this #define usage seems to be a ticking bomb ready to blow up if someone
> forgets to correctly adjust all the numbers.
Well, I guess it is hard to forget to adjust the others when you change
them.
> Why aren't we using an enum {} ?
Do you think it would be cleaner? I am all for having cleaner (and
easier to understand) code, so if you can cook up a patch that would
be fine.
And cleanups are recommended in general. Sometimes it is difficult to
understand what is going on, so patches adding good comments are also ok.
--
To unsubscribe, send mail to [email protected].