Yes, I have two screens. I also get the weird maximized behavior from
Inkscape but I think that is unrelated as everything else works fine.
On Sep 29, 2015 10:24 AM, "Szymon Hennel" <szymon.hen...@gmail.com> wrote:

> I have just discovered that the behavior is more complex than just
> treating any click as mod4+button1 : Inkscape jumps between screens, but
> not within a single screen. If I reduce my setup to only one screen, there
> is no problem. Let me explain this better :
>
> I have 2 screens, both showing their first tag, using the layout
> awful.layout.suit.tile. I have a bunch on xterms on each screen. I open
> inskape on screen 1, it starts maximized even though I have the rule
>
>     { rule = { class = "Inkscape" },
>       properties = {maximized_horizontal = false, maximized_vertical =
> false } },
>
> With mod4+button1, I can drag it around screen1 and make it jump between
> the possible positions in the tiling scheme, I can also drag it over to
> screen 2 in a controlled way.
>
> If I left click on inkscape and drag towards screen 2 (nothing should
> happen), then it immediately jumps to screen2, without going through
> available positition within the tiling scheme of screen 1. I can not drag
> it around screen 2 either, all I can do is make it it go back to its
> initial position on screen 1 if I drag the mouse in the other direction.
>
> Do you guys have multiple screens?
>
>
>
>
> On 2015-09-29 15:40, Maxwell Anselm wrote:
>
> No problem here either, with the same versions as lilydjwg.
>
> My config
>
> https://github.com/silverhammermba/.files/blob/bet/awesome/.config/awesome/rc.lua
>
> On Tue, Sep 29, 2015 at 9:31 AM, lilydjwg <lilyd...@gmail.com> wrote:
>
>> On Tue, Sep 29, 2015 at 11:54:03AM +0200, Szymon Hennel wrote:
>> > Hi,
>> >
>> > I have the same issue, so it's unlikely to be an error in your config.
>> > Left-Clicking and dragging on any pixel that does not belong to the
>> document
>> > or to a button is interpreted as mod4+button1.
>>
>> I don't have the issue. It works quite well for me. Here's my config:
>> https://github.com/lilydjwg/myawesomerc
>>
>> Versions:
>>
>> awesome 3.5.6-2
>> inkscape 0.91-9
>>
>> --
>> Best regards,
>> lilydjwg
>>
>> --
>> To unsubscribe, send mail to awesome-unsubscr...@naquadah.org.
>>
>
>
>

Reply via email to