I tried to download backuppc-4.1.3 tar file from the backuppc website.

The upgrade went fine, I went through the upgrade steps and no error was shown, 
however, the backuppc.server won't start now?

In the GUI, I'm getting.....
Error: Unable to connect to BackupPC server
This CGI script (/backuppc/index.cgi) is unable to connect to the BackupPC 
server on backuppc01 port -1.
The error was: unix connect: No such file or directory.
Perhaps the BackupPC server is not running or there is a configuration error. 
Please report this to your Sys Admin.

And when I try to run "service backuppc restart", Im getting.....

Job for backuppc.service failed because the control process exited with error 
code. See "systemctl status backuppc.service" and "journalctl -xe" for details.

And when I run "systemctl status backuppc.service", Im getting.....

backuppc.service - LSB: Launch backuppc server
Loaded: loaded (/etc/init.d/backuppc; bad; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2018-01-31 09:33:33 GMT; 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 29163 ExecStop=/etc/init.d/backuppc stop (code=exited, 
status=0/SUCCESS)
Process: 29425 ExecStart=/etc/init.d/backuppc start (code=exited, 
status=1/FAILURE)
Jan 31 09:33:33 backuppc01 systemd[1]: Starting LSB: Launch backuppc server...
Jan 31 09:33:33 backuppc01 backuppc[29425]:  * Starting backuppc...
Jan 31 09:33:33 backuppc01 backuppc[29425]: BackupPC cannot be started because 
important parameters are missing from config.pl.
Jan 31 09:33:33 backuppc01 backuppc[29425]: If you just upgraded BackupPC, 
please update /etc/backuppc/config.pl.
Jan 31 09:33:33 backuppc01 systemd[1]: backuppc.service: Control process 
exited, code=exited status=1
Jan 31 09:33:33 backuppc01 systemd[1]: Failed to start LSB: Launch backuppc 
server.
Jan 31 09:33:33 backuppc01 systemd[1]: backuppc.service: Unit entered failed 
state.
Jan 31 09:33:33 backuppc01 systemd[1]: backuppc.service: Failed with result 
'exit-code'.

I followed the upgrade instructions correctly.

And when I go into the GUI....

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to 
complete your request.
Please contact the server administrator at webmaster@localhost to inform them 
of the time this error occurred, and the actions you performed just before this 
error.
More information about this error may be available in the server error log.
________________________________
Apache/2.4.18 (Ubuntu) Server at backuppc01.dsdb.int Port 80

Before the upgrade, I was running smbd 4.3.11-Ubuntu and backuppc 
3.3.1-2ubuntu3.3

Any ideas or suggestions on how to fix this, please? This is our only source of 
backing up our servers.

I have no working backuppc now...any ideas, please?

------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
BackupPC-users mailing list
BackupPC-users@lists.sourceforge.net
List:    https://lists.sourceforge.net/lists/listinfo/backuppc-users
Wiki:    http://backuppc.wiki.sourceforge.net
Project: http://backuppc.sourceforge.net/

Reply via email to