--- Em ter, 13/11/12, Armin K. escreveu:

> De: Armin K. <kre...@email.com>
> Assunto: Re: [blfs-dev] libsoup-2.40.1
> Para: "BLFS Development List"
> Data: Terça-feira, 13 de Novembro de 2012, 16:33
> On 11/13/2012 06:01 PM, Fernando de
> Oliveira wrote:
> >
> > Armin, I have it erased, glib-2.34.1 installed, so
> libsoup-2.40.1 has configured , mde and installed properly.
> >
> > Thus, I have trimmed a copy of the whole build log to
> just the first unfinished one and attached, perhaps it will
> be enough.
> >
> Apparently you were missing either glib pkg-config files
> (.pc ones) or 
> development headers. This was error in your config.log
> configure:12019: checking for GLIB - version >= 2.33.1
> configure:12152: result: no
> configure:12180: gcc -o conftest -g -O2   
> conftest.c   >&5
> conftest.c:24:18: fatal error: glib.h: No such file or
> directory
> Glad you've fixed it.

Thanks, Armin, for your attention.

But they both are there (I left VMWLFS7.1 with libsoup in its older
version for a while, to discuss better this matter):

$ find /usr -name glib.h  -exec ls -lh {} \; -o -name glib\*.pc -exec ls -lh {} 
\; 2>/dev/null
-rw-r--r-- 1 root root 3,3K Mai  8  2012 /usr/include/glib-2.0/glib.h
-rw-r--r-- 1 root root 392 Mai  8  2012 /usr/lib/pkgconfig/glib-2.0.pc
-rw-r--r-- 1 root root 579 Abr 17  2012 /usr/lib/pkgconfig/glibmm-2.4.pc

Problem was with the version, as I understood in the first reference to
the error. That is the reason I upgraded it, so fixed the problem.

My real question is related to the libsoup's "Required" section in the

If a package A cannot be built for some dependency B is missing or
obsolete, should not it be included as required directly?

I did not need to upgrade any other dependency, just glib-2.32.3 to

FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to