On 07/04/2018 11:57 μμ, Ken Moffat wrote:
Does anyone here use a ryzen ?  I got a 1300X recently, and building
current rustc - and using that to build firefox - seems to work
fine.  BUT - I had not bothered to run the rustc testsuite because
it takes so long.

But those initial builds of rustc were to install it in /opt -
seemed good enough, so I decided to install it in /usr and to see
how the test results looked.  Disaster.

Every time I run the tests, within a couple of minutes I get two
traps for invalid opcodes, followed a few minutes later by two
segfaults (noted by reading syslog, the tests seem to continue as
normal).  But if I leave the tests running, about 20 to 30 minutes
later (before the end of the tests, according to what got written
to the log) the machine reboots.  These are all that got logged the
first time, nothingrelated to the reboot.

Apr  6 06:37:48 origin kernel: [ 3695.201558] traps: backtrace.stage[17714] 
trap invalid opcode ip:7f1e76696498 sp:7ffc6848af80 error:0 in 
Apr  6 06:37:48 origin kernel: [ 3695.231521] traps: backtrace.stage[17720] 
trap invalid opcode ip:7f76e0ff0498 sp:7ffc2bf46850 error:0 in 
Apr  6 06:41:17 origin kernel: [ 3903.999612] segfault-no-out[31250]: segfault 
at 0 ip 0000555aa6cd0b69 sp 00007ffeb0d96fa0 error 6 in 
Apr  6 06:41:23 origin kernel: [ 3910.633482] signal-exit-sta[32055]: segfault 
at 1 ip 000055afe3b44efc sp 00007fffc985f660 error 6 in 
Apr  6 06:41:26 origin kernel: [ 3913.231883] traps: simd-target-fea[32330] 
trap invalid opcode ip:55b72481e89c sp:7fff97757750 error:0 in 

Now that I know it will reboot, I've spend some hours trying to work
around this (I'm assuming it uses opcodes not valid on Ryzen, but
for somiething which is only exercised by the testsuite) - failed
completely - and eventually raised an issue.

However, I've now looked at rustc-1.22.1 and that too gets the same
two traps.  so, I'm thinking that I should put a big warning in the
book to not run the tests on a Ryzen.

But confirmation that the tests segfault on somebody else's ryzen
would be conclusive, which is why I'm asking: has anyone already run
the rustc tests on a ryzen ?  If not, is anybody willing to give it
a go on a ryzen ?  Waiting for it to reboot is not required, just
keep an eye on the system log or journal and stop the tests if the
segfaults occur.

My machine otherwise seems stable (I replaced the nvidia graphics
card with a low-nd radeon because nouveau frequently locked up X,
since then it has seemed fine apart from this.  And no, I'm not
overclocking, the CPU seems to run cool (maximum I've seen was low
50s degrees).

I was going to get an 8 core 16 thread Ryzen, but after the problems
they exhibited I decided to get a 4 core 4 thread 3 1200 for now,
and upgrade when Ryzen 2 comes out, be tested and proved to be stable.

I knew that I needed a host with latest gcc to build LFS, so I used Fedora 27 with gcc-7.3. Everything went smoothly, except some core
dumps during the gcc tests. I ran the tests only for the recommended
by the book packages.

The only problem the machine had was freezing on idle. In the beginning
I disabled the cool 'n quiet in the bios and that solved the problem.
Then I found this bug report,


enabled cool 'n quiet, tried the proposed RCU solution and it worked.
Since then the system is rock stable. Cpu at stock speed, 32GB ram at
rated 3200MHz. Ram speed is not that important for our use, but I
favored that ram kit because it is one of the most compatible with
Ryzen according many testers' and users' reports.

On my svn installation I have rust-1.25.0 and used that to build
firefox-59.0.2. When I read your mail I installed gdb and rebuilt
to run the tests. No reboots. About 15 tests dumped core. Iindicatively:

systemd-coredump[2185]: Process 2172 (issue-24313.sta) of user 1001 dumped core.

Stack trace of thread 2183:
#0  0x00007f7f8e582e5b __GI_raise (libc.so.6)
#1  0x00007f7f8e584211 __GI_abort (libc.so.6)
#2 0x00007f7f8edb2339 _ZN3std3sys4unix14abort_internal17he99af7afd6098d88E (libstd-23815cc482a70678.so) #3 0x00007f7f8edc6a8b _ZN3std10sys_common4util5abort17h240ecd99fa33591bE (libstd-23815cc482a70678.so)
#4  0x00007f7f8ed976a2 rust_panic (libstd-23815cc482a70678.so)
#5 0x00007f7f8ed975c2 _ZN3std9panicking20rust_panic_with_hook17hfcd2a02d3b761d28E (libstd-23815cc482a70678.so) #6 0x00005602b2dc24c4 n/a (/build/tmp/rustc-1.25.0-src/build/x86_64-unknown-linux-gnu/test/run-pass/issue-24313.stage2-x86_64-unknown-linux-gnu)

3 traps:

Απρ 08 02:17:50 kernel: traps: backtrace.stage[11039] trap invalid opcode ip:7fd12c93a488 sp:7ffc99eb6230 error:0 in libstd-23815cc482a70678.so[7fd12c8e0000+154000]

Απρ 08 02:17:50 kernel: traps: backtrace.stage[11079] trap invalid opcode ip:7f8652d97488 sp:7ffc5aae6000 error:0 in libstd-23815cc482a70678.so[7f8652d3d000+154000]

Απρ 08 02:22:03 kernel: traps: simd-target-fea[25911] trap invalid opcode ip:56325971a88c sp:7ffe1a3878d0 error:0 in simd-target-feature-mixup.stage2-x86_64-unknown-linux-gnu[563259717000+7000]


grep 'running .* tests' ../rustc-testlog | awk '{ sum += $2 } END { print sum }'

grep '^test result:' ../rustc-testlog | awk '{ sum += $6 } END { print sum }'

grep '^test result:' ../rustc-testlog | awk '{ sum += $4 } END { print sum }'

grep '^test result:' ../rustc-testlog | awk '{ sum += $8 } END { print sum }'

grep '^test result:' ../rustc-testlog | awk '{ sum += $10 } END { print sum }'

grep '^test result:' ../rustc-testlog | awk '{ sum += $12 } END { print sum }'

FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Reply via email to