[quoted lines by Tage Johansson on 2019/12/03 at 06:49 +0100]

>I have successfully installed brltty on my raspberry pi with arch linux arm
>through the official brltty package for arch linux arm. For some reason,
>espeak isn't working on arch linux arm, but espeak-ng does. But for some
>other reason, espeak-ng isn't working together with brltty. I have uncomment
>the line in brltty which enables espeak-ng and set autospeak to yes, but I'm
>still not hearing any sound. I've tested espeak-ng and it works if I run it
>from the command line, both as user and root.

Brltty does work with eSpeak-NG. Could you please post your brltty.conf so that
we can have a look at it? You can directly test it by running brltty with the
-sen command line option.

It could be that the brltty you're using doesn't include the eSpeak-NG driver.
The output of brltty -v should show which drivers it contains.

>Any suggestions how to proceed? I can build brltty from source if someone
>just tells me how to configure it so it includes espeak-ng. 

The "trick" is to ensure that you have eSpeak-NG's development package
installed.

-- 
I believe the Bible to be the very Word of God: http://Mielke.cc/bible/
Dave Mielke            | 2213 Fox Crescent | WebHome: http://Mielke.cc/
EMail: d...@mielke.cc  | Ottawa, Ontario   | Twitter: @Dave_Mielke
Phone: +1 613 726 0014 | Canada  K2A 1H7   |
_______________________________________________
This message was sent via the BRLTTY mailing list.
To post a message, send an e-mail to: BRLTTY@brltty.app
For general information, go to: http://brltty.app/mailman/listinfo/brltty

Reply via email to