We work with svn were we've committed the schema classes also into the
Using the Catalyst helper script we tried to update the DBIC schema
that was created with
the Catalyst helper after checkout on another machine and the
following error appeared.

DBIx::Class::Schema::Loader::make_schema_at(): It is not possible to
"downgrade" a schema that was loaded with use_moose => 1 to use_moose
=> 0, due to differing custom content at
/home/danny/perl5/lib/perl5/Catalyst/Helper/Model/DBIC/Schema.pm line

I have to mention that we work both on Linux (Ubuntu) and Windows (7)
configurations. The error appeared after building the schema on the
Windows machine; checking it in and subsequently rebuilding (after
changes) on Ubuntu.

We also tried to install the latest version of DBIx::Class::Schema::Loader and
the latest Catalyst helper, and then the latest DBIx::Class, and run the
Catalyst helper to update the schema, but it still gives that error.

What can we do? Where can we specify use_moose => 1 to make it work?

We've looked into documentation but there is no mention about a best
practice of keeping the schema files out of a shared repository. Or am
I confused here?
I also noted that a similar question was posed on the DBIX mailing
list, but IMHO this list might be more appropriate.

Cheers & thanks in advance,

Piet Molenaar
Department of Oncogenomics, M1-131
Academic Medical Center
University of Amsterdam
Meibergdreef 9
1105 AZ Amsterdam
the Netherlands

tel (+31) 20-5666592
fax (+31) 20-6918626
List: Catalyst@lists.scsys.co.uk
Listinfo: http://lists.scsys.co.uk/cgi-bin/mailman/listinfo/catalyst
Searchable archive: http://www.mail-archive.com/catalyst@lists.scsys.co.uk/
Dev site: http://dev.catalyst.perl.org/

Reply via email to