>learning PHP to increase my marketability Just a thought here. When there are thousands of cheap PHP programmers running around looking for projects. I would think your return on investment in learning PHP is going to be very small.
Learning something that is growing and the demand is already outpacing the number of coders means you ROI would be far larger. May I suggest learning Flex and AIR instead. You can get far more bang for your time with this. Plus if you already know CF, this is all in the family so-to-speak. On the Apache/PHP setup, unless you are learning to be a Sys admin. I would just download a prepared VM appliance that already has everything setup for you. No reason to lose more hair over this :) Here's one called LAMP (Linux,Apache,MySQL,PHP) http://virtualappliances.net/products/lamp.php The wwwroot is open to Microsoft folder sharing. So you can simply run this appliance and write the PHP files over the share directory. John Mason [EMAIL PROTECTED] 770.337.8363 www.FusionLink.com - ColdFusion and Flex hosting Now offering ColdFusion 8 Enterprise hosting FREE Subversion hosting -----Original Message----- From: Phillip M. Vector [mailto:[EMAIL PROTECTED] Sent: Friday, February 08, 2008 6:31 PM To: CF-Talk Subject: Apache and CF7 After trying to redo my CF 7 set up with apache (because I also want to start learning PHP to increase my marketability, I have this error. ============== The Apache service named reported the following error: >>> httpd.exe: Syntax error on line 485 of C:/Program Files/Apache Software Foundation/Apache2.2/conf/httpd.conf: Cannot load C:/CFusionMX7/runtime/lib/wsconfig/1/mod_jrun20.so into server: The specified procedure could not be found. ============== I added this to the httpd.conf at the end and yes, I verified the file is there. ============== # JRun Settings LoadModule jrun_module "c:/CFusionMX7/runtime/lib/wsconfig/1/mod_jrun20.so" <IfModule mod_jrun.c> JRunConfig Verbose false JRunConfig Apialloc false JRunConfig Ssl false JRunConfig IgnoreSuffixmap false JRunConfig Serverstore "c:/CFusionMX7/runtime/lib/wsconfig/1/jrunserver.store" JRunConfig Bootstrap 127.0.0.1:51000 #JRunConfig Errorurl <optionally redirect to this URL on errors> JRunConfig jrun-handler .jsp .jws .cfm .cfml .cfc .cfswf .cfr </IfModule> ============== When I try to go to the page, I get a "download" box to download the cfm file. Most likely because I couldn't get this active to reconize the cfm file to process via the jrun server. So my apache won't even start up now and I'm going bald.. Any ideas on what could be causing the trouble and how to fix it? ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~| Adobe® ColdFusion® 8 software 8 is the most important and dramatic release to date Get the Free Trial http://ad.doubleclick.net/clk;160198600;22374440;w Archive: http://www.houseoffusion.com/groups/CF-Talk/message.cfm/messageid:298588 Subscription: http://www.houseoffusion.com/groups/CF-Talk/subscribe.cfm Unsubscribe: http://www.houseoffusion.com/cf_lists/unsubscribe.cfm?user=11502.10531.4

