On Fri, Sep 16, 2016, at 11:11 PM, Shane Stanley wrote:
> On 15 Sep 2016, at 2:54 PM, Kyle Sluder <k...@ksluder.com> wrote:
> > 
> > On Wed, Sep 14, 2016, at 07:50 PM, Shane Stanley wrote:
> >> Under 10.12 GM, I'm seeing entries like this in Console:
> >> 
> >> NSToolbarItem (<NSToolbarItem: 0x618000138060>) had to adjust the size of
> >> <NSButton: 0x618000144c50> from {38, 25} to the expected size of {40,
> >> 27}. Make sure that this toolbar item view has a valid frame/min/max
> >> size. This is an app bug, please do not file a bug against AppKit or
> >> NSToolbar! Break on _NSToolbarAdjustedBorderedControlSizeBreakpoint
> >> 
> >> I'm seeing it in a couple of apps -- one using a standard nib approach,
> >> and one generating the toolbar fully in code. 
> >> 
> >> In the nib one, the toolbar has buttons on the toolbar items, and IB
> >> won't even allow any size other than 25px deep. I've tried fiddling with
> >> the toolbar item sizes, to no avail. I added the suggested breakpoint,
> >> but I don't see it break. If the message weren't so adamant, I'd be
> >> inclined to question it.
> >> 
> >> Anyone else seen it, or have suggestions?
> > 
> > What’s your app’s deployment target? What’s the deployment target of
> > your nib (listed in the file inspector while the nib is open for
> > editing)?
> I checked under the latest(?) GM, and it's still showing "Deployment
> Target(10.9)".
> For anyone seeing the same thing, the solution seems to be to change the
> max size of the toolbar items to the unexpected "expected" size.

Yes, the intent of the warning message is to get you to do that. But
since you’re linking against and deploying to Mavericks, I fear you’ll
wind up with too-big buttons on older OSes. Could you please file a bug
report with a sample project attached, and send me the bug number?

> I
> thought I'd already tried this without success, until I realized what was
> happening: I had edited the values, then closed the toolbar editor in IB.
> I've now realised that the changes were not being saved; when I reopened
> the toolbar editor, the old values were still showing. Running once with
> the toolbar editor open seems to have made the changes 'take". (And yes,
> I tried cleaning at various stages.)

This sounds worthy of investigation. Could you please file a bug report
detailing the _exact_ steps that resulted in your changes being
forgotten? Send me that bug number too please.

> Along the way I discovered another problem in Xcode 8: setting a button
> to image-only in IB still shows any title if there is one.

I think we have a bug report on this already. In the meantime, if you
clear out the Title property, please make sure to populate the relevant
Accessibility properties.

--Kyle Sluder


Cocoa-dev mailing list (Cocoa-dev@lists.apple.com)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:

This email sent to arch...@mail-archive.com

Reply via email to