[ 
https://issues.apache.org/jira/browse/CASSANDRA-9303?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15064115#comment-15064115
 ] 

Paulo Motta commented on CASSANDRA-9303:
----------------------------------------

Looking very good, I tested the new config options and the ingest rate is now 
working like a charm. Some follow-up comments below:

bq. Done, I cleaned up the options a bit as well and removed the helper methods 
in the main cqlsh files.

* I was initially thinking that while \[copy\] is a global section, 
\[copy-from*\] and \[copy-to*\] are exclusive sections for these commands, so 
for example if you define INGESTRATE by mistake in the \[copy-to\] section it's 
not picked up by a copy-from execution.
* Can you also add some examples to {{conf/cqlshrc.sample}} ? And maybe also 
update the cql protocol version there which is quite old.
* Also in the {{Reading options from /home/paulo/.cqlsh/cqlshrc}} message, 
maybe print which options are being read to improve clarity (don't worry if not 
straightforward)

bq. If a file from a previous execution exists it will be ranamed to 
.YYYYMMDD_HHMMSS.

Cool! Since it's an edge-case I guess we can omit in the help and print a 
message instead in case it happens.

bq. So, I converted SKIPCOLS to a COPY FROM option and changed its semantic to 
just skip columns that exist in the file.

Sounds good, it just seems the skipped columns is still being printed on the 
message {{Starting copy of keyspace1.standard1 with columns \['key', 'C0', 
'C1', 'C2', 'C3', 'C4'\].}} (you fixed before, but it came back somehow).

Minor code style nits:

* Move csv_dialect_defaults from cqlsh.py to copyutil.py
* Move exclusive skip_columns field from CopyTask to ImportTask
* csv_options are a bit misleading since they are not exclusive csv-related 
options, can we maybe rename the tuple CopyOptions(csv, dialect, unrecognized) 
to Options(copy, dialect, unrecognized)?

We're getting there, I guess we'll be done by next round. :)

> Match cassandra-loader options in COPY FROM
> -------------------------------------------
>
>                 Key: CASSANDRA-9303
>                 URL: https://issues.apache.org/jira/browse/CASSANDRA-9303
>             Project: Cassandra
>          Issue Type: New Feature
>          Components: Tools
>            Reporter: Jonathan Ellis
>            Assignee: Stefania
>            Priority: Critical
>             Fix For: 2.1.x
>
>
> https://github.com/brianmhess/cassandra-loader added a bunch of options to 
> handle real world requirements, we should match those.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to