[
https://issues.apache.org/jira/browse/HADOOP-10727?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14046155#comment-14046155
]
Babak Behzad commented on HADOOP-10727:
---------------------------------------
Thanks [~cwimmer]. I like your idea of making it configurable. We can put it as
a new option in "hadoop-metrics2.properties" file along with other options such
as server_host, server_port and metrics_prefix. Following the naming convention
of Graphite we can have the following line to replace all the "." to ":":
*.sink.graphite.escape_character=:
Default is _ (Underscore).
> GraphiteSink metric names should not contain "."
> ------------------------------------------------
>
> Key: HADOOP-10727
> URL: https://issues.apache.org/jira/browse/HADOOP-10727
> Project: Hadoop Common
> Issue Type: Improvement
> Reporter: Babak Behzad
> Priority: Minor
>
> Sometimes the names of the metrics sent to Graphite contain "." in them (such
> as hostnames). Graphite interpret these dots as a separator for directories
> causing long directory hierarchies. It would be easier to replace them to "_"
> in order to have easier to read metric names.
--
This message was sent by Atlassian JIRA
(v6.2#6252)