Am 28.08.2011 22:54, schrieb Mario Torre:
Il giorno dom, 28/08/2011 alle 21.35 +0200, Sebastian Sickelmann ha
scritto:
Hi, here is a webrev[1] for some cleanup that i want to integrated in
tl-repositories.
Hi,
Hi created a new webrev with your suggested changes at:
http://oss-patches.24.eu/openjdk8/InternalError/part2/7084245_main_1/
I have created some comments inline in this mail.
The patch seems good for me (speaking in particular about the AWT/2D
part), and I don't think it will introduce any side effects.

Just a note:

src/share/classes/java/lang/invoke/CallSite.java:

          } catch (ReflectiveOperationException ignore) {
-            throw new InternalError();
+            throw new InternalError(ignore);
          }

Being a refactoring patch, I would not change the name from "ignore" to
the more classical "e", since we are not ignoring the exception anymore.

Also in src/share/classes/com/sun/servicetag/BrowserSupport.java, it
seems to me that you can also aggregate the InvocationTargetException in
the multi catch.
I think we should not make further aggregating on InvocationTargetException
in this patch. It changes behavoir. Which of the two places to you mean we can
aggregate into multi catch?
In fact, the block could be probably rewritten to take advantage of
ReflectiveOperationException.

Same for src/share/classes/sun/misc/Launcher.java,
src/share/classes/sun/security/util/SecurityConstants.java and
src/share/classes/sun/tracing/dtrace/DTraceProvider.java
Changed that to ReflectiveOperationException.
Cheers,
Mario

-- Sebastian

Reply via email to