> Some of the code that creates various encoding properties at JVM > initialization time, such as file.encoding and native.encoding, could use > some cleaning up. Cleanup is fairly minimal and should be mostly > behavior-preserving. Changes include the following: > > * In the java_props.h and java_props_md.c files, add documentation and > asserts that the sprops.encoding and sprops.sun_jnu_encoding members are > always set to non-NULL by the platform-specific code. > > * In SystemProps.java, remove a null check that is now extraneous based on > the above assertion. > > * In SystemProps.java, rearrange logic (with no behavior change) around > handling of the "COMPAT" value for the file.encoding property. > > * In SystemProps.Raw, rename the platform properties array index from > _file_encoding_NDX to _native_encoding_NDX. > > * In SystemProps.Raw.cmdProperties(), adjust the HashMap size computation. > This should actually avoid resizing of the HashMap (unlike the earlier code). > > * Adjust various comments in several places for clarity and correctness.
Stuart Marks has updated the pull request incrementally with one additional commit since the last revision: Fix comment from file.encoding to native.encoding ------------- Changes: - all: https://git.openjdk.org/jdk/pull/24463/files - new: https://git.openjdk.org/jdk/pull/24463/files/f5ba54f9..e8f3d35e Webrevs: - full: https://webrevs.openjdk.org/?repo=jdk&pr=24463&range=01 - incr: https://webrevs.openjdk.org/?repo=jdk&pr=24463&range=00-01 Stats: 1 line in 1 file changed: 0 ins; 0 del; 1 mod Patch: https://git.openjdk.org/jdk/pull/24463.diff Fetch: git fetch https://git.openjdk.org/jdk.git pull/24463/head:pull/24463 PR: https://git.openjdk.org/jdk/pull/24463